ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Srimanth Gunturi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-6628) Cannot start ambari-server due to empty metainfo table
Date Sun, 27 Jul 2014 18:02:38 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-6628?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Srimanth Gunturi updated AMBARI-6628:
-------------------------------------

    Attachment: AMBARI-6628_2.patch

Fixing Sumit's review recommendations.

> Cannot start ambari-server due to empty metainfo table
> ------------------------------------------------------
>
>                 Key: AMBARI-6628
>                 URL: https://issues.apache.org/jira/browse/AMBARI-6628
>             Project: Ambari
>          Issue Type: Bug
>          Components: controller
>    Affects Versions: 1.7.0
>            Reporter: Srimanth Gunturi
>            Assignee: Srimanth Gunturi
>            Priority: Blocker
>             Fix For: 1.7.0
>
>         Attachments: AMBARI-6628.patch, AMBARI-6628_2.patch
>
>
> Trying to deploy latest trunk build _ambari-server-1.7.0-70_ and hit the following when
running _ambari-server start_
> ambari-server.log
> {code}
> 01:30:53,074  INFO [main] AmbariServer:157 - ********* Meta Info initialized **********
> 01:30:53,086  INFO [main] ClustersImpl:103 - Initializing the ClustersImpl
> 01:30:53,679  INFO [main] AmbariManagementControllerImpl:230 - Initializing the AmbariManagementControllerImpl
> 01:30:53,894  INFO [main] AmbariServer:487 - Checking DB store version
> 01:30:53,894  WARN [main] AmbariServer:502 - Current database store version is not compatible
with current server version, serverVersion=null, schemaVersion=null
> 01:30:53,895 ERROR [main] AmbariServer:592 - Failed to run the Ambari Server
> org.apache.ambari.server.AmbariException: Current database store version is not compatible
with current server version, serverVersion=null, schemaVersion=null
> 	at org.apache.ambari.server.controller.AmbariServer.checkDBVersion(AmbariServer.java:503)
> 	at org.apache.ambari.server.controller.AmbariServer.run(AmbariServer.java:164)
> 	at org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:589)
> {code}
> The metainfo table is empty with no values indicating version of Ambari installed.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message