ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mahadev konar (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-6602) Error upgrading from 1.6.0 to 1.6.1 using external Postgres DB
Date Thu, 24 Jul 2014 21:46:39 GMT
Mahadev konar created AMBARI-6602:
-------------------------------------

             Summary: Error upgrading from 1.6.0 to 1.6.1 using external Postgres DB
                 Key: AMBARI-6602
                 URL: https://issues.apache.org/jira/browse/AMBARI-6602
             Project: Ambari
          Issue Type: Bug
    Affects Versions: 1.7.0
            Reporter: Mahadev konar
            Assignee: Myroslav Papirkovskyy
             Fix For: 1.7.0


Error upgrading from 1.6.0 to 1.6.1 using external Postgres DB

14:16:57,645 WARN [main] DBAccessorImpl:478 - Error executing query: ALTER SCHEMA postgres
OWNER TO "XXXX"; 
org.postgresql.util.PSQLException: ERROR: schema "YYYY" does not exist 
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2161)

at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1890) 
at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:255) 
at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:559) 
at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:403)

at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:395) 
at org.apache.ambari.server.orm.DBAccessorImpl.executeQuery(DBAccessorImpl.java:475) 
at org.apache.ambari.server.orm.DBAccessorImpl.executeQuery(DBAccessorImpl.java:461) 
at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.changePostgresSearchPath(AbstractUpgradeCatalog.java:169)

at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.upgradeSchema(AbstractUpgradeCatalog.java:252)

at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeUpgrade(SchemaUpgradeHelper.java:178)

at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:238)



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message