ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Hill (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-6556) Not able to stop components that are in maintenance mode
Date Wed, 23 Jul 2014 14:22:38 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-6556?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Greg Hill updated AMBARI-6556:
------------------------------

    Description: 
There was a bug introduced in 1.6.1 where it is no longer possible to stop components that
are in maintenance mode.  It just returns a 200 status with an empty message body and does
not stop the components.

The API calls I'm using are:

Setting maintenance mode:

PUT /clusters/testcluster/hosts/c6401.ambari.apache.org/host_components?fields=HostRoles/state
       {
            "RequestInfo": {
                "context" :"Start Maintanence Mode",
            }, 
            "Body": {
                "HostRoles": {"maintenance_state": "ON"},
            },
        }

Stopping all components:

PUT /clusters/testcluster/hosts/c6401.ambari.apache.org/host_components?fields=HostRoles/state
       {
            "RequestInfo": {
                "context" :"Stop All Components",
            }, 
            "Body": {
                "HostRoles": {"state": "INSTALLED"},
            },
        }

  was:There was a bug introduced in 1.6.1 where it is no longer possible to stop components
that are in maintenance mode.  It just returns a 200 status with an empty message body and
does not stop the components.


> Not able to stop components that are in maintenance mode
> --------------------------------------------------------
>
>                 Key: AMBARI-6556
>                 URL: https://issues.apache.org/jira/browse/AMBARI-6556
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 1.6.1
>            Reporter: Greg Hill
>
> There was a bug introduced in 1.6.1 where it is no longer possible to stop components
that are in maintenance mode.  It just returns a 200 status with an empty message body and
does not stop the components.
> The API calls I'm using are:
> Setting maintenance mode:
> PUT /clusters/testcluster/hosts/c6401.ambari.apache.org/host_components?fields=HostRoles/state
>        {
>             "RequestInfo": {
>                 "context" :"Start Maintanence Mode",
>             }, 
>             "Body": {
>                 "HostRoles": {"maintenance_state": "ON"},
>             },
>         }
> Stopping all components:
> PUT /clusters/testcluster/hosts/c6401.ambari.apache.org/host_components?fields=HostRoles/state
>        {
>             "RequestInfo": {
>                 "context" :"Stop All Components",
>             }, 
>             "Body": {
>                 "HostRoles": {"state": "INSTALLED"},
>             },
>         }



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message