ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonenko Alexander (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-6472) Add Service Wizard corrupts the zookeeper config for existing Storm service
Date Sun, 13 Jul 2014 12:56:05 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-6472?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14060100#comment-14060100
] 

Antonenko Alexander commented on AMBARI-6472:
---------------------------------------------

received +1 for the patch, from [~u39kun]

> Add Service Wizard corrupts the zookeeper config for existing Storm service
> ---------------------------------------------------------------------------
>
>                 Key: AMBARI-6472
>                 URL: https://issues.apache.org/jira/browse/AMBARI-6472
>             Project: Ambari
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.6.1
>            Reporter: Antonenko Alexander
>            Assignee: Antonenko Alexander
>            Priority: Critical
>             Fix For: 1.6.1
>
>         Attachments: BUG-20099_branch-1.6.1.patch, BUG-20099_trunk.patch
>
>
> STR:
> 1. On a cluster with Storm already installed, run Add Service Wizard to install an additional
service not already part of the cluster (say, Falcon, but it doesn't matter which service).
> 2. Try to restart Storm.  Nimbus/Supervisor will not be able to start
> Note that adding Storm itself via Add Service Wizard works fine.
> This corruption happens when adding a non-Storm service.
> The reason is Add Service Wizard updates storm-site and in doing so, corrupts *storm.zookeeper.servers*
property.
> Before running Add Service Wizard:
> {noformat}
> storm.zookeeper.servers: "['c6401.ambari.apache.org','c6402.ambari.apache.org','c6403.ambari.apache.org']"
> {noformat}
> After completing Add Service Wizard to add another service:
> {noformat}
> storm.zookeeper.servers: "'['c6401.ambari.apache.org','c6402.ambari.apache.org','c6403.ambari.apache.org']'",
> {noformat}
> After completing Add Service Wizard again to add another service:
> {noformat}
> storm.zookeeper.servers: "''['c6401.ambari.apache.org','c6402.ambari.apache.org','c6403.ambari.apache.org']''",
> {noformat}
> Note that every time Add Service Wizard runs, extra single quotes are added around the
ZK array.
> *Workaround*
> After running Add Service Wizard, go to Services > Storm > Config and hit Save.
 This fixes *storm.zookeeper.servers* and Nimbus/Supervisors will be able to start.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message