ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-6368) deprecated messge printed during ambari-server setup
Date Wed, 02 Jul 2014 21:27:24 GMT
Andrew Onischuk created AMBARI-6368:
---------------------------------------

             Summary: deprecated messge printed during ambari-server setup
                 Key: AMBARI-6368
                 URL: https://issues.apache.org/jira/browse/AMBARI-6368
             Project: Ambari
          Issue Type: Bug
            Reporter: Andrew Onischuk
            Assignee: Andrew Onischuk
             Fix For: 1.7.0


I was performing ambari-server setup and during jdk download, i hit ctrl-c.

I ran setup again and since I had a partial JDK file, I got a warning error (a
good thing) saying it tried to install the jdk (based on the partial file) and
that failed. It said do you want to download again (a good thing). I said y
and continued.

That's all fine except when it said tried to install jdk failed it also showed
a deprecated message. That could alarm users. See below.

    
    
    
    Setup ambari-server
    Checking SELinux...
    SELinux status is 'disabled'
    Ambari-server daemon is configured to run under user 'root'. Change this setting [y/n]
(n)? 
    Adjusting ambari-server permissions and ownership...
    Checking iptables...
    Checking JDK...
    [1] - Oracle JDK 1.7
    [2] - Oracle JDK 1.6
    [3] - Custom JDK
    ==============================================================================
    Enter choice (1): 
    JDK already exists, using /var/lib/ambari-server/resources/jdk-7u45-linux-x64.tar.gz
    Installing JDK to /usr/jdk64
    /usr/sbin/ambari-server.py:1856: DeprecationWarning: BaseException.message has been deprecated
as of Python 2.6
      print "Installation of JDK has failed: %s\n" % e.message
    Installation of JDK has failed: 
    
    JDK found at /var/lib/ambari-server/resources/jdk-7u45-linux-x64.tar.gz. Would you like
to re-download the JDK [y/n] (y)? 
    jd
    





--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message