ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk" <aonis...@hortonworks.com>
Subject Review Request 23746: In Ubuntu host, failed to install and register Ambari agents
Date Mon, 21 Jul 2014 17:39:30 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23746/
-----------------------------------------------------------

Review request for Ambari and Dmitro Lisnichenko.


Bugs: AMBARI-6552
    https://issues.apache.org/jira/browse/AMBARI-6552


Repository: ambari


Description
-------

Installation and registration Ambari agent failed in Ubuntu12, see following
error:  
==========================  
Running setup agent script...  
==========================

Command start time 2014-07-21 01:50:40  
Verifying Python version compatibility...  
Using python /usr/bin/python2.7  
ambari-agent is not running. No PID found at /var/run/ambari-agent/ambari-
agent.pid

{'exitstatus': 1, 'log': 'Desired version (1.7.0) of ambari-agent package is
not available. Repository has following versions of ambari-agent:1.7.0,'}

Connection to u1201.ambari.apache.org closed.  
SSH command execution finished  
host=u1201.ambari.apache.org, exitcode=1  
Command end time 2014-07-21 01:50:42

ERROR: Bootstrap of host u1201.ambari.apache.org fails because previous action
finished with non-zero exit code (1)  
ERROR MESSAGE: Connection to u1201.ambari.apache.org closed.

Ambari server log is attached.

ambari-server --hash  
8abd488f7d01e9d95a01bf611b854bd1988e78c1


Diffs
-----

  ambari-server/src/main/python/setupAgent.py 7e5524d 

Diff: https://reviews.apache.org/r/23746/diff/


Testing
-------

mvn clean test


Thanks,

Andrew Onischuk


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message