ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Srimanth Gunturi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-6300) Configurations UI takes 1.5minutes to load on a 2k node cluster
Date Fri, 27 Jun 2014 01:18:24 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-6300?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14045409#comment-14045409
] 

Srimanth Gunturi commented on AMBARI-6300:
------------------------------------------

Just for calculating default configurations, we load all the host_components on all hosts.
This call takes 1 minute. 
Changes have been made to only load host_components as needed for calculating defaults/validations.

Review at https://reviews.apache.org/r/23102/

> Configurations UI takes 1.5minutes to load on a 2k node cluster
> ---------------------------------------------------------------
>
>                 Key: AMBARI-6300
>                 URL: https://issues.apache.org/jira/browse/AMBARI-6300
>             Project: Ambari
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.6.1
>            Reporter: Srimanth Gunturi
>            Assignee: Srimanth Gunturi
>             Fix For: 1.6.1
>
>
> On a 2k node cluster when user visits configurations tab, it sometimes takes 1.5 minutes
to load. This is mostly in YARN service configurations.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message