ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonenko Alexander (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-6145) npm peerdependencies errors during package install.
Date Mon, 16 Jun 2014 18:44:02 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-6145?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Antonenko Alexander updated AMBARI-6145:
----------------------------------------

    Attachment: AMBARI-6145.patch

> npm peerdependencies errors during package install.
> ---------------------------------------------------
>
>                 Key: AMBARI-6145
>                 URL: https://issues.apache.org/jira/browse/AMBARI-6145
>             Project: Ambari
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.6.1
>            Reporter: Antonenko Alexander
>            Assignee: Antonenko Alexander
>             Fix For: 1.6.1
>
>         Attachments: AMBARI-6145.patch
>
>
> During running {{npm install}} command some errors thrown for karma package dependencies.
> {noformat}
> ambari-web-compile:
>      [exec] npm WARN package.json Ambari@1.0.0 No README data
>      [exec] npm ERR! peerinvalid The package karma does not satisfy its siblings' peerDependencies
requirements!
>      [exec] npm ERR! peerinvalid Peer karma-mocha@0.1.4 wants karma@>=0.12.8
>      [exec] npm ERR! peerinvalid Peer karma-chai@0.1.0 wants karma@>=0.10.9
>      [exec] npm ERR! peerinvalid Peer karma-sinon@1.0.3 wants karma@>=0.10
>      [exec] npm ERR! peerinvalid Peer karma-phantomjs-launcher@0.1.4 wants karma@>=0.9
>      [exec] npm ERR! peerinvalid Peer karma-coverage@0.2.4 wants karma@>=0.9
>      [exec] npm ERR! peerinvalid Peer karma-commonjs-require@0.0.2 wants karma@>=0.9
>      [exec]
>      [exec] npm ERR! System Linux 3.13.0-29-generic
>      [exec] npm ERR! command "node" "/usr/local/bin/npm" "install"
>      [exec] npm ERR! cwd /home/lestat/git/ambari/ambari-web
>      [exec] npm ERR! node -v v0.10.25
>      [exec] npm ERR! npm -v 1.4.3
>      [exec] npm ERR! code EPEERINVALID
>      [exec] npm ERR!
>      [exec] npm ERR! Additional logging details can be found in:
>      [exec] npm ERR!     /home/lestat/git/ambari/ambari-web/npm-debug.log
>      [exec] npm ERR! not ok code 0
>      [exec] Result: 1
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message