ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-6109) Nagios installation failed due to incompatible nagios-plugins version
Date Fri, 13 Jun 2014 09:47:02 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-6109?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk resolved AMBARI-6109.
-------------------------------------

    Resolution: Fixed

Committed to trunk

> Nagios installation failed due to incompatible nagios-plugins version
> ---------------------------------------------------------------------
>
>                 Key: AMBARI-6109
>                 URL: https://issues.apache.org/jira/browse/AMBARI-6109
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 1.6.1
>
>
> Nagios sever installation failed due to following error:
>     
>     
>     
>     2014-06-13 00:40:53,984 - Error while executing command 'install':
>     Traceback (most recent call last):
>       File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 111, in execute
>         method(env)
>       File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/services/NAGIOS/package/scripts/nagios_server.py",
line 32, in install
>         self.install_packages(env)
>       File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 167, in install_packages
>         Package(name)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line
148, in __init__
>         self.env.run()
>       File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py",
line 149, in run
>         self.run_action(resource, action)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py",
line 115, in run_action
>         provider_action()
>       File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 40, in action_install
>         self.install_package(package_name)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/zypper.py",
line 36, in install_package
>         shell.checked_call(cmd)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
35, in checked_call
>         return _call(command, logoutput, True, cwd, env, preexec_fn, user, wait_for_finish,
timeout)
>       File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line
90, in _call
>         raise Fail(err_msg)
>     Fail: Execution of '/usr/bin/zypper --quiet install --auto-agree-with-licenses --no-confirm
nagios-plugins-1.4.9' returned 4. Problem: cannot install both nagios-plugins-1.4.13-1.35.x86_64
and nagios-plugins-1.4.9-1.x86_64
>      Solution 1: Following actions will be done:
>       downgrade of nagios-plugins-1.4.13-1.35.x86_64 to nagios-plugins-1.4.9-1.x86_64
>       install nagios-plugins-1.4.9-1.x86_64 (with vendor change)
>         SUSE LINUX Products GmbH, Nuernberg, Germany  -->  Nagios Plugin Development
Group
>      Solution 2: do not ask to install a solvable providing nagios-plugins = 1.4.9
>     
> rpm -qa | grep nagios  
> nagios-plugins-1.4.13-1.35  
> hdp_mon_nagios_addons-1.2.2-1  
> nagios-3.5.0-99



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message