ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Speidel (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-6041) Cluster create via blueprint fails when using an existing DB or hive metastore
Date Thu, 05 Jun 2014 17:53:01 GMT
John Speidel created AMBARI-6041:
------------------------------------

             Summary: Cluster create via blueprint fails when using an existing DB or hive
metastore
                 Key: AMBARI-6041
                 URL: https://issues.apache.org/jira/browse/AMBARI-6041
             Project: Ambari
          Issue Type: Bug
    Affects Versions: 1.6.0
            Reporter: John Speidel
            Assignee: John Speidel
             Fix For: 1.6.1


When deploying a cluster via a blueprint where the MYSQL_SERVER or HIVE_METASTORE are not
included in the topology but are instead already existing, a 400 response is returned to the
user even if the user properly configured the necessary configurations for an existing server.

{ 
"status" : 400, "message" : "Unable to update configuration properties with topology information.
Component 'MYSQL_SERVER' is not mapped to any host group or is mapped to multiple groups."

}

This occurs when deploying the cluster when the configurations are updated with topology related
information. For components that may be external, we need to check if the user updated the
default hostname or port in the corresponding configuration and if they have, don't do any
topology update on the property.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message