ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Harp (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-5888) Nagios is not stopping on sles11
Date Fri, 06 Jun 2014 23:30:03 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-5888?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14020528#comment-14020528
] 

Michael Harp commented on AMBARI-5888:
--------------------------------------

Found a related problem, restarting nagios in the gui when nagios is stopped fails.
Workaround;
{code}
sed -i "/No lock file found in/N;s/exit 1/#exit 1/" /etc/init.d/nagios
{code}


> Nagios is not stopping on sles11
> --------------------------------
>
>                 Key: AMBARI-5888
>                 URL: https://issues.apache.org/jira/browse/AMBARI-5888
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 1.6.0
>         Environment: sles11 Only issue
>            Reporter: Michael Harp
>            Priority: Critical
>             Fix For: 1.6.1
>
>
> `service nagios start` creates /var/run/nagios/nagios.pid correctly but `service nagios
stop` checks /var/run/nagios.pid for the process id and the kill command fails since /var/run/nagios.pid
is an empty file.
> This error is caused by hardcoded pid location in /etc/init.d/nagios, "NagiosRunFile=/var/run/nagios.pid".
Changing to "NagiosRunFile=/var/run/nagios/nagios.pid" is our current workaround.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message