ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk" <aonis...@hortonworks.com>
Subject Re: Review Request 22818: After Ambari upgraded to 1.6.1, Hive, Oozie and Nagios failed to start
Date Fri, 20 Jun 2014 17:06:26 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/22818/
-----------------------------------------------------------

(Updated June 20, 2014, 5:06 p.m.)


Review request for Ambari and Myroslav Papirkovskyy.


Bugs: AMBARI-6223
    https://issues.apache.org/jira/browse/AMBARI-6223


Repository: ambari


Description
-------

STR  
1\. Upgrade Ambari server from 1.4.1 to 1.6.1.

2\. After upgrading, restart all services.

Results:  
Hive, Oozie and Nagios fail to start due to a similar error(Fail:
Configuration parameter 'xxxxxx' was not found in configurations dictionary)

See attached error logs

This issue is also reproducible when upgrading from 1.5.0 and 1.5.1


Diffs
-----

  ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog161.java 9f38f18

  ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog161Test.java
f70fcd4 

Diff: https://reviews.apache.org/r/22818/diff/


Testing
-------

mvn clean test


Thanks,

Andrew Onischuk


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message