ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk" <aonis...@hortonworks.com>
Subject Re: Review Request 22208: Incorrect behaviour when trying to execute upgradestack to nonexistent HDP version
Date Fri, 06 Jun 2014 13:52:42 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/22208/
-----------------------------------------------------------

(Updated June 6, 2014, 1:52 p.m.)


Review request for Ambari and Dmitro Lisnichenko.


Changes
-------

Exception changes made


Bugs: AMBARI-6008
    https://issues.apache.org/jira/browse/AMBARI-6008


Repository: ambari


Description
-------


    [root@dev01 ~]# ambari-server upgradestack HDP-2.3.4
    Using python  /usr/bin/python2.6
    Upgrading stack of ambari-server
    WARNING: could not change directory to "/root"
    
    Ambari Server 'upgradestack' completed successfully.
    

Ambari should consider the validity of the data if was specified the invalid
HDP version and give the correct message about this.


Diffs (updated)
-----

  ambari-server/src/main/java/org/apache/ambari/server/upgrade/StackUpgradeHelper.java 77ec069

  ambari-server/src/main/python/ambari-server.py d580634 
  ambari-server/src/test/java/org/apache/ambari/server/upgrade/StackUpgradeHelperTest.java
PRE-CREATION 
  ambari-server/src/test/python/TestAmbariServer.py 0ed238a 

Diff: https://reviews.apache.org/r/22208/diff/


Testing
-------

mvn clean test


Thanks,

Andrew Onischuk


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message