ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Foley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-5888) Nagios is not stopping on sles11
Date Thu, 29 May 2014 23:10:01 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-5888?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14013075#comment-14013075
] 

Matt Foley commented on AMBARI-5888:
------------------------------------

Mike reports this workaround:

sed -i "s|/var/run/nagios.pid|/var/run/nagios/nagios.pid|g" /etc/init.d/nagios;rm -f /var/run/nagios.pid

Looks like a pretty simple change to the /etc/init.d/nagios file is needed (for SLES11 only).

> Nagios is not stopping on sles11
> --------------------------------
>
>                 Key: AMBARI-5888
>                 URL: https://issues.apache.org/jira/browse/AMBARI-5888
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 1.6.0
>         Environment: sles11 Only issue
>            Reporter: Michael Harp
>            Priority: Critical
>             Fix For: 1.6.1
>
>
> `service flume start` creates /var/run/nagios/nagios.pid correctly but `service flume
stop` checks /var/run/nagios.pid for the process id and the kill command fails since /var/run/nagios.pid
is an empty file.
> This error is caused by hardcoded pid location in /etc/init.d/nagios, "NagiosRunFile=/var/run/nagios.pid".
Changing to "NagiosRunFile=/var/run/nagios/nagios.pid" is our current workaround.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message