ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-5689) In some cases automated agent setup doesn't work
Date Tue, 06 May 2014 17:19:38 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-5689?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Lysnichenko updated AMBARI-5689:
---------------------------------------

    Description: 
setupAgent.py will fail in such test scenarios:
- In case if script will be started without parameters - script will failed without reasonable
error output. 
- In case if script will be started without passed project version string and repository in
the system will contain at least one available version of agent.
  For example:  
       function call retcode = getOptimalVersion("")  will always return exitcode 1, as any
founded in repository version will not match blank string
- In case if script will be started without passed project version.
  Error output will fail, because of projectVersion variable will contain "None" type, not
string.
- In case if repository will contain several versions of packages with versions like "1.0.1,
1.0.3-SNAPSHOT, 1.0.5"  getAvaliableAgentPackageVersions and findNearestAgentPackageVersion
functions will return wrong result "1.0.1, 1.0.3" and version 1.0.5 will be missed.

  was:
setupAgent.py will fail in such test scenarios:
In case if script will be started without parameters - script will failed without reasonable
error output.
In case if script will be started without passed project version string and repository in
the system will contain at least one available version of agent.
For example: 
function call retcode = getOptimalVersion("") will always return exitcode 1, as any founded
in repository version will not match blank string
In case if script will be started without passed project version.
Error output will fail, because of projectVersion variable will contain "None" type, not string.
In case if repository will contain several versions of packages with versions like "1.0.1,
1.0.3-SNAPSHOT, 1.0.5" getAvaliableAgentPackageVersions and findNearestAgentPackageVersion
functions will return wrong result "1.0.1, 1.0.3" and version 1.0.5 will be missed.


> In some cases automated agent setup doesn't work
> ------------------------------------------------
>
>                 Key: AMBARI-5689
>                 URL: https://issues.apache.org/jira/browse/AMBARI-5689
>             Project: Ambari
>          Issue Type: Task
>          Components: agent
>    Affects Versions: 1.6.0
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 1.7.0
>
>
> setupAgent.py will fail in such test scenarios:
> - In case if script will be started without parameters - script will failed without reasonable
error output. 
> - In case if script will be started without passed project version string and repository
in the system will contain at least one available version of agent.
>   For example:  
>        function call retcode = getOptimalVersion("")  will always return exitcode 1,
as any founded in repository version will not match blank string
> - In case if script will be started without passed project version.
>   Error output will fail, because of projectVersion variable will contain "None" type,
not string.
> - In case if repository will contain several versions of packages with versions like
"1.0.1, 1.0.3-SNAPSHOT, 1.0.5"  getAvaliableAgentPackageVersions and findNearestAgentPackageVersion
functions will return wrong result "1.0.1, 1.0.3" and version 1.0.5 will be missed.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message