ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-5653) Upgradestack only handles specific OSs
Date Thu, 01 May 2014 21:12:15 GMT
Nate Cole created AMBARI-5653:
---------------------------------

             Summary: Upgradestack only handles specific OSs
                 Key: AMBARI-5653
                 URL: https://issues.apache.org/jira/browse/AMBARI-5653
             Project: Ambari
          Issue Type: Bug
          Components: controller
            Reporter: Nate Cole
            Assignee: Nate Cole
             Fix For: 1.6.0


"ambari-server upgradestack" will only work with specific OSs: redhat5, redhat6 and suse11,
whereas in pre-1.6.0 releases, users could also specify other OSs in the same family (such
as centos5, centos6, etc).

This change means this command now fails to run:

ambari-server upgradestack HDP-2.1 http://test centos6

{code}
01:16:41,187 ERROR [main] StackUpgradeHelper:168 - Caught exception on upgrade. Exiting...
org.apache.ambari.server.StackAccessException: Stack data, stackName=HDP, stackVersion=2.1,
osType=centos6, repoId=HDP-2.1
	at org.apache.ambari.server.api.services.AmbariMetaInfo.getRepository(AmbariMetaInfo.java:331)
	at org.apache.ambari.server.api.services.AmbariMetaInfo.updateRepoBaseURL(AmbariMetaInfo.java:908)
	at org.apache.ambari.server.upgrade.StackUpgradeUtil.updateLocalRepo(StackUpgradeUtil.java:185)
	at org.apache.ambari.server.upgrade.StackUpgradeHelper.updateStackVersion(StackUpgradeHelper.java:117)
	at org.apache.ambari.server.upgrade.StackUpgradeHelper.main(StackUpgradeHelper.java:158)
{code}

But this runs:

ambari-server upgradestack HDP-2.1 http://test redhat6



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message