ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gordon Hamilton (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-5599) Switching between existing configs is not working in API
Date Mon, 28 Apr 2014 18:10:14 GMT
Gordon Hamilton created AMBARI-5599:
---------------------------------------

             Summary: Switching between existing configs is not working in API
                 Key: AMBARI-5599
                 URL: https://issues.apache.org/jira/browse/AMBARI-5599
             Project: Ambari
          Issue Type: Bug
    Affects Versions: 1.5.0, 1.5.1
            Reporter: Gordon Hamilton


In 1.4.x, I was able to switch between configurations using the following curl command:
{code}
curl -u <user>:<password> -X PUT -H "X-Requested-By: ml" http://<address>:8080/api/v1/cluster/AMCluster1
-d '{"Clusters":{"desired_config":{"type":"hdfs-site","tag":"version1"}}}'
{code}

However, in 1.5.x, this doesn't appear to work anymore even though documentation suggests
it should. https://github.com/apache/ambari/blob/trunk/ambari-server/docs/api/v1/configuration.md

I now see the following error:
{code}
{
  "status" : 500,
  "message" : "org.apache.ambari.server.controller.spi.SystemException: An internal system
exception occurred: Configuration with tag 'version1' exists for 'hdfs-site'"
}
{code}

The work-around for this is to perform a GET on previous configuration that is required and
create it as a new configuration, setting the desired_config at the same time.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message