ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonenko Alexander (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-5484) When ATS is not running, Jobs page just shows "Loading..." forever
Date Wed, 16 Apr 2014 16:50:18 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-5484?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Antonenko Alexander updated AMBARI-5484:
----------------------------------------

    Attachment: AMBARI-5484.patch

> When ATS is not running, Jobs page just shows "Loading..." forever
> ------------------------------------------------------------------
>
>                 Key: AMBARI-5484
>                 URL: https://issues.apache.org/jira/browse/AMBARI-5484
>             Project: Ambari
>          Issue Type: Task
>          Components: client
>    Affects Versions: 1.6.0
>            Reporter: Antonenko Alexander
>            Assignee: Antonenko Alexander
>             Fix For: 1.6.0
>
>         Attachments: AMBARI-5484.patch, Screen Shot 2014-04-10 at 11.14.31 AM.png
>
>
> See attached.
> 1. We can proactively detect that ATS is not running, and show an appropriate error message
saying "Jobs data cannot be shown since YARN App Timeline Server is not running."
> 2. We need a generic error handling in case of 400 from server, saying "Unable to load
data." instead of showing "Loading..." forever.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message