ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myroslav Papirkovskyy (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-5382) Schema Upgrade failed when upgrading to 1.5.1
Date Mon, 07 Apr 2014 19:15:15 GMT
Myroslav Papirkovskyy created AMBARI-5382:
---------------------------------------------

             Summary: Schema Upgrade failed when upgrading to 1.5.1
                 Key: AMBARI-5382
                 URL: https://issues.apache.org/jira/browse/AMBARI-5382
             Project: Ambari
          Issue Type: Bug
          Components: controller
    Affects Versions: 1.5.1
            Reporter: Myroslav Papirkovskyy
            Assignee: Myroslav Papirkovskyy
            Priority: Critical
             Fix For: 1.5.1


While upgrade, schema upgrade fails.
Example error output (Oracle):
{code}
rg.apache.ambari.server.AmbariException: Current database store version is not compatible
with current server version, serverVersion=1.5.1.96, schemaVersion=1.4.1.25
	at org.apache.ambari.server.controller.AmbariServer.checkDBVersion(AmbariServer.java:479)
	at org.apache.ambari.server.controller.AmbariServer.run(AmbariServer.java:149)
	at org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:528)
{code}
and Postgres 
{code}
11:39:27,364 ERROR [main] AmbariServer:531 - Failed to run the Ambari Server
org.apache.ambari.server.AmbariException: Current database store version is not compatible
with current server version, serverVersion=1.5.1.96, schemaVersion=1.5.0
	at org.apache.ambari.server.controller.AmbariServer.checkDBVersion(AmbariServer.java:479)
	at org.apache.ambari.server.controller.AmbariServer.run(AmbariServer.java:149)
	at org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:528)

{code}




--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message