ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmytro Sen (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-5368) HDP 2.1 install leaves deprecated params in mapred-site.xml, causes Hive failure
Date Sun, 06 Apr 2014 21:23:14 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-5368?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmytro Sen resolved AMBARI-5368.
--------------------------------

    Resolution: Fixed

Committed to trunk and branch-1.5.1

> HDP 2.1 install leaves deprecated params in mapred-site.xml, causes Hive failure
> --------------------------------------------------------------------------------
>
>                 Key: AMBARI-5368
>                 URL: https://issues.apache.org/jira/browse/AMBARI-5368
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 1.5.0
>            Reporter: Dmytro Sen
>            Assignee: Dmytro Sen
>             Fix For: 1.5.1
>
>
> If Ambari 1.5.0 to install HDP 2.1, Hive fails. Tracing leads to a pair of deprecated
params in mapred-site.xml. Removing the two params caused the Hive problem to go away. 
> Mapred-site.xml having both new and deprecated properties. After deleting deprecated
property hive works as expected.
> (ref: http://hadoop.apache.org/docs/r2.3.0/hadoop-project-dist/hadoop-common/DeprecatedProperties.html)
> | mapred.map.child.java.opts	| mapreduce.map.java.opts |
> | mapred.reduce.child.java.opts 	| mapreduce.reduce.java.opts |
> The problem is eliminated if I execute the following after installation:
> sh /var/lib/ambari-server/resources/scripts/configs.sh -u admin -p admin -port 8081 delete
localhost c1 mapred-site mapred.map.child.java.optssh /var/lib/ambari-server/resources/scripts/configs.sh
-u admin -p admin -port 8081 delete localhost c1 mapred-site mapred.reduce.child.java.opts



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message