ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vitalyi Brodetskyi" <vbrodets...@hortonworks.com>
Subject Re: Review Request 18772: After configuring NNHA, nn process alerts don't work
Date Wed, 05 Mar 2014 17:41:48 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/18772/
-----------------------------------------------------------

(Updated March 5, 2014, 5:41 p.m.)


Review request for Ambari, Dmitro Lisnichenko and Nate Cole.


Changes
-------

Nate, code changes according to your comment were done.


Bugs: AMBARI-4954
    https://issues.apache.org/jira/browse/AMBARI-4954


Repository: ambari


Description
-------

1) Configure NN HA
2) stack 2.0.6 (but check stack 2.1 as well)
3) Two alerts show" check_tcp: Port must be a positive integer"

NameNode process on c6401.ambari.apache.org
NameNode process on c6402.ambari.apache.org

4) Looked at /etc/nagios/objects/hadoop-services.cfg
5) Saw:

{code}
define service {
        host_name               c6401.ambari.apache.org
        use                     hadoop-service
        service_description     NAMENODE::NameNode process on c6401.ambari.apache.org
        servicegroups           HDFS
        check_command           check_tcp_wrapper!//test!-w 1 -c 1
        normal_check_interval   0.5
        retry_check_interval    0.25
        max_check_attempts      3
}
define service {
        host_name               c6402.ambari.apache.org
        use                     hadoop-service
        service_description     NAMENODE::NameNode process on c6402.ambari.apache.org
        servicegroups           HDFS
        check_command           check_tcp_wrapper!//test!-w 1 -c 1
        normal_check_interval   0.5
        retry_check_interval    0.25
        max_check_attempts      3
}
{code}

Notice in the above *//test* is the name of my nameservice.

Attaching screen shot of my config. So looks like it's grabbing port from the wrong prop.


Diffs (updated)
-----

  ambari-server/src/main/resources/stacks/HDP/2.0.6/services/NAGIOS/package/scripts/params.py
813c626 
  ambari-server/src/main/resources/stacks/HDP/2.0.6/services/NAGIOS/package/templates/hadoop-services.cfg.j2
6df0380 

Diff: https://reviews.apache.org/r/18772/diff/


Testing
-------


Thanks,

Vitalyi Brodetskyi


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message