ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole" <nc...@hortonworks.com>
Subject Re: Review Request 18772: After configuring NNHA, nn process alerts don't work
Date Wed, 05 Mar 2014 15:29:58 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/18772/#review36228
-----------------------------------------------------------



ambari-server/src/main/resources/stacks/HDP/2.0.6/services/NAGIOS/package/templates/hadoop-services.cfg.j2
<https://reviews.apache.org/r/18772/#comment67169>

    I realize it's sometimes convenient to put logic into template files, but it makes it
harder to maintain.  Can we keep the logic in the params.py script and just "resolve the port"
so to speak there, and just use a single value in the template file?


- Nate Cole


On March 5, 2014, 10:22 a.m., Vitalyi Brodetskyi wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/18772/
> -----------------------------------------------------------
> 
> (Updated March 5, 2014, 10:22 a.m.)
> 
> 
> Review request for Ambari, Dmitro Lisnichenko and Nate Cole.
> 
> 
> Bugs: AMBARI-4954
>     https://issues.apache.org/jira/browse/AMBARI-4954
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> 1) Configure NN HA
> 2) stack 2.0.6 (but check stack 2.1 as well)
> 3) Two alerts show" check_tcp: Port must be a positive integer"
> 
> NameNode process on c6401.ambari.apache.org
> NameNode process on c6402.ambari.apache.org
> 
> 4) Looked at /etc/nagios/objects/hadoop-services.cfg
> 5) Saw:
> 
> {code}
> define service {
>         host_name               c6401.ambari.apache.org
>         use                     hadoop-service
>         service_description     NAMENODE::NameNode process on c6401.ambari.apache.org
>         servicegroups           HDFS
>         check_command           check_tcp_wrapper!//test!-w 1 -c 1
>         normal_check_interval   0.5
>         retry_check_interval    0.25
>         max_check_attempts      3
> }
> define service {
>         host_name               c6402.ambari.apache.org
>         use                     hadoop-service
>         service_description     NAMENODE::NameNode process on c6402.ambari.apache.org
>         servicegroups           HDFS
>         check_command           check_tcp_wrapper!//test!-w 1 -c 1
>         normal_check_interval   0.5
>         retry_check_interval    0.25
>         max_check_attempts      3
> }
> {code}
> 
> Notice in the above *//test* is the name of my nameservice.
> 
> Attaching screen shot of my config. So looks like it's grabbing port from the wrong prop.
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/resources/stacks/HDP/2.0.6/services/NAGIOS/package/scripts/params.py
813c626 
>   ambari-server/src/main/resources/stacks/HDP/2.0.6/services/NAGIOS/package/templates/hadoop-services.cfg.j2
5b8fb6d 
> 
> Diff: https://reviews.apache.org/r/18772/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Vitalyi Brodetskyi
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message