ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (AMBARI-4633) Security_enabled was not send when adding service. Add service failed
Date Thu, 13 Feb 2014 19:43:20 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-4633?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk reopened AMBARI-4633:
-------------------------------------


> Security_enabled was not send when adding service. Add service failed
> ---------------------------------------------------------------------
>
>                 Key: AMBARI-4633
>                 URL: https://issues.apache.org/jira/browse/AMBARI-4633
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 1.5.0
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>         Attachments: AMBARI-4633.patch
>
>
> We are sending security_enabled parameter. If it's not present it's a bug that will hit
web-ui behavior. 
> But this parameter is solely used by web-ui code. Puppet uses _core-site/hadoop.security.authentication_
for determining cluster security status.
> The relevant code is at {{ambari-agent/src/main/puppet/modules/hdp/manifests/params.pp}}
> {code}
> ##### for secure install
>   $hadoop_security_authenticatoin = hdp_default("core-site/hadoop.security.authentication",
"simple")
>   
>   $security_enabled = $hadoop_security_authenticatoin ? {
>     'kerberos' => true,
>     default => false,
>   }
> {code}



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message