ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yusaku Sako (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-3987) Resource providers are set with wrong stack version.
Date Thu, 05 Dec 2013 22:13:35 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-3987?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Yusaku Sako updated AMBARI-3987:
--------------------------------

    Fix Version/s: 1.4.2

> Resource providers are set with wrong stack version.
> ----------------------------------------------------
>
>                 Key: AMBARI-3987
>                 URL: https://issues.apache.org/jira/browse/AMBARI-3987
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 1.4.2
>            Reporter: Tom Beerbower
>            Assignee: Tom Beerbower
>             Fix For: 1.4.2
>
>         Attachments: AMBARI-3987.patch
>
>
> AbstractProviderModule.updateClusterVersion sets the cluster version for the resource
providers with the following ...
> {code}
>          PropertyHelper.MetricsVersion version =  clusterVersion.startsWith("HDP-1")
?
>               PropertyHelper.MetricsVersion.HDP1 : PropertyHelper.MetricsVersion.HDP2;
> {code}
> So, the Cluster/version property set to "HDPLocal-1.3.2" will incorrectly be detected
as HDP2.  This causes the property providers to use the wrong metric mapping files which causes
many JMX properties not to be set properly.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message