ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oleg Nechiporenko (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-3954) hbase.zookeeper.quorum changing inconsistently on hosts after adding ZookeeperServer
Date Mon, 09 Dec 2013 13:32:08 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-3954?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Oleg Nechiporenko updated AMBARI-3954:
--------------------------------------

    Attachment: AMBARI-3954(2).patch
                AMBARI-3954-1.4.2(2).patch

> hbase.zookeeper.quorum changing inconsistently on hosts after adding ZookeeperServer
> ------------------------------------------------------------------------------------
>
>                 Key: AMBARI-3954
>                 URL: https://issues.apache.org/jira/browse/AMBARI-3954
>             Project: Ambari
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.2
>            Reporter: Oleg Nechiporenko
>            Assignee: Oleg Nechiporenko
>             Fix For: 1.4.2
>
>         Attachments: AMBARI-3954(2).patch, AMBARI-3954-1.4.2(2).patch, AMBARI-3954-1.4.2.patch,
AMBARI-3954.patch
>
>
> *Issue 1:*
> Steps followed: 
> *1*. Install a 3-node cluster with Hbase and Zookeeper and 3 zookeeper servers. 
> *2*. After installation on each host the property 
> *hbase.zookeeper.quorum* in */etc/hbase/conf/hbase-site.xml* has:
> {noformat}
> <name>hbase.zookeeper.quorum</name>
>     <value>c6401.ambari.apache.org,c6402.ambari.apache.org,c6403.ambari.apache.org</value>
> {noformat}
> *3*. After adding a host with Hbase Region Server, and after that a ZookeeperServer to
it, the property on the added c6404.ambari.apache.org host has the same value, as in *2*.

> *4*. After restarting HBase master on c6401 (which is proposed by UI), the 
> property value on c6401 becomes: 
> {noformat}
>     <name>hbase.zookeeper.quorum</name>
>     <value>c6401.ambari.apache.org</value>
> {noformat}. On other hosts it remains unchanged. 
> *5.* After restarting HbaseRegionServers on the rest of the hosts (not proposed by ui),
the property changes too, to the same value, as in *4*. 
> __________________________________________________________
> *Issue 2:*
> Property *templeton.zookeeper.hosts* in */etc/hcatalog/conf/webhcat-site.xml*
> Prior to adding a zookeeperServer on host c6404, config on WebHCat server lookes like:
> {noformat}
> [root@c6402 vagrant]# cat /etc/hcatalog/conf/webhcat-site.xml |grep  templeton.zookeeper.hosts
-C 2
>   <configuration>
>     <property>
>     <name>templeton.zookeeper.hosts</name>
>     <value>c6401.ambari.apache.org:2181,c6402.ambari.apache.org:2181,c6403.ambari.apache.org:2181</value>
>   </property>
> {noformat}
> After adding a ZookeeperServer on c6404 and restarting WebHCatServer on c6402: 
> {noformat}
> [root@c6402 vagrant]# cat /etc/hcatalog/conf/webhcat-site.xml |grep  templeton.zookeeper.hosts
-C 2
>   </property>
>     <property>
>     <name>templeton.zookeeper.hosts</name>
>     <value>c6401.ambari.apache.org</value>
>   </property>
> {noformat}
> __________________________________________________________
> *Issue 3*. 
> On a 3-node cluster with HA-enbaled,  property *ha.zookeeper.quorum* in */etc/hadoop/conf/core-site.xml*,
has the same value on all hosts: 
> {noformat}
>     <name>ha.zookeeper.quorum</name>    <value>c6401.ambari.apache.org:2181,c6402.ambari.apache.org:2181,c6403.ambari.apache.org:2181</value>
> {noformat}
> It doesn't change on either of the hosts after adding c6404 to the cluster, installing
ZookeeperServer on it and restarting HDFS. 



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message