ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrii Tkach (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-3855) YARN Client restart indicator not shown on host configs page
Date Fri, 22 Nov 2013 13:22:40 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-3855?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13829945#comment-13829945
] 

Andrii Tkach commented on AMBARI-3855:
--------------------------------------

+1 for the patch.

> YARN Client restart indicator not shown on host configs page
> ------------------------------------------------------------
>
>                 Key: AMBARI-3855
>                 URL: https://issues.apache.org/jira/browse/AMBARI-3855
>             Project: Ambari
>          Issue Type: Task
>          Components: client
>    Affects Versions: 1.4.3
>            Reporter: Aleksandr Kovalenko
>            Assignee: Aleksandr Kovalenko
>            Priority: Critical
>             Fix For: 1.4.3
>
>         Attachments: AMBARI-3855.patch
>
>
> I had a config-group with 2 hosts which had YARN_CLIENTs and NodeManagers. When I changed
configs in that config-group, it correctly showed on the service page the component-count
and the hosts-count. 
> However when you go to the host page and restart only the NodeManager, there is no warning
for the YARN_CLIENT needing restart. However when I look at the API below, the YARN_CLIENT
for the host is shown as stale.
> {noformat}
> http://server:8080/api/v1/clusters/c1/host_components?fields=HostRoles/component_name&HostRoles/stale_configs=true
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message