ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sumit Mohanty (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-1594) Ambari UI shows failed services while processes are running on the server
Date Fri, 08 Mar 2013 18:36:13 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-1594?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13597382#comment-13597382
] 

Sumit Mohanty commented on AMBARI-1594:
---------------------------------------

+1
                
> Ambari UI shows failed services while processes are running on the server
> -------------------------------------------------------------------------
>
>                 Key: AMBARI-1594
>                 URL: https://issues.apache.org/jira/browse/AMBARI-1594
>             Project: Ambari
>          Issue Type: Bug
>          Components: agent
>    Affects Versions: 1.2.2
>            Reporter: Siddharth Wagle
>            Assignee: Siddharth Wagle
>             Fix For: 1.2.2
>
>         Attachments: AMBARI-1594.patch
>
>
> PROBLEM: Ambari UI shows failed services while processes are running on the server 
> STEPS TO REPRODUCE: create custom PID directory during Ambari installation and check
if UI shows that service down while it is running on the server.
> ACTUAL BEHAVIOR: Ambari UI shows that service like namenode is down
> EXPECTED BEHAVIOR: Show correct status of the service
> The issue was caused because custom PID directory was not created and ambari agent was
not able to find the service pid. This issue was corrected on cluster by linking two directories:
> #ln -s /var/hadoop/run /kohls/hadoop/run
> This issue was seen for namenode, jobtracker, and hive

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message