ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mahadev Konar <maha...@hortonworks.com>
Subject Re: Encounter some trouble when the agent registering to the server
Date Fri, 01 Feb 2013 08:47:27 GMT
Great to see it being resolved. Thanks!

On Fri, Feb 1, 2013 at 12:35 AM, 范振华 <fanbinnet@gmail.com> wrote:
> Hi,
>
> Thanks for the response .
> But I have work through this issue by manually install agent and edit the
> server host name in file " /etc/ambari-agent/ambari-agent.ini".
>
> The log didn't keep,if I encounter this issue again,I will send the log to
> you .
>
> Thanks very much!
>
> Regards,
> Shrek Fan
>
>
> 2013/2/1 Mahadev Konar <mahadev@hortonworks.com>
>
>> Hey fanbinnet,
>>  Can you check for the logs in ambari-agent:
>>
>>  /var/log/ambari-agent/ambari-agent.log to see why its not registering
>> with the server?
>>
>> mahadev
>>
>>
>> On Thu, Jan 31, 2013 at 6:50 AM, 范振华 <fanbinnet@gmail.com> wrote:
>> > Hi
>> >
>> > My os is centos6 and I install both ambari-server and agent in a single
>> > computer.
>> > But at the step 3,the agent always registering failed.
>> >
>> > I have run ambari-server start and ambari-agent status,and all the
>> services
>> > is running.
>> >
>> > Below is the log:
>> >
>> >
>> >
>> > STDOUT
>> >
>> > STDERR
>> > STDOUT
>> >
>> > STDERR
>> > STDOUT
>> > Verifying Python version compatibility...
>> > Using python  /usr/bin/python2.6
>> > Checking for previously running Ambari Agent...
>> > ERROR: ambari-agent already running
>> > Check /var/run/ambari-agent/ambari-agent.pid for PID.
>> > ('hostname: ok bogon
>> > ip: ok 220.250.64.225
>> > cpu: ok Intel(R) Core(TM)2 Duo CPU     T6600  @ 2.20GHz
>> > Intel(R) Core(TM)2 Duo CPU     T6600  @ 2.20GHz
>> > memory: ok 5.68179 GB
>> > disks: ok
>> >  \xe6\x96\x87\xe4\xbb\xb6\xe7\xb3\xbb\xe7\xbb\x9f\t
>> > \xe5\xae\xb9\xe9\x87\x8f  \xe5\xb7\xb2\xe7\x94\xa8
>> > \xe5\x8f\xaf\xe7\x94\xa8 \xe5\xb7\xb2\xe7\x94\xa8%%
>> > \xe6\x8c\x82\xe8\xbd\xbd\xe7\x82\xb9
>> > /dev/sda9              19G  5.9G   12G  34% /
>> > tmpfs                 2.9G  272K  2.9G   1% /dev/shm
>> > os: ok CentOS release 6.3 (Final)
>> > iptables: ok
>> >  Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
>> >  pkts bytes target     prot opt in     out     source
>> > destination
>> >
>> > Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
>> >  pkts bytes target     prot opt in     out     source
>> > destination
>> >
>> > Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
>> >  pkts bytes target     prot opt in     out     source
>> destination
>> > selinux: ok SELINUX=disabled
>> > SELINUXTYPE=targeted
>> > yum: ok yum-3.2.29-30.el6.centos.noarch
>> > rpm: ok rpm-4.8.0-27.el6.x86_64
>> > openssl: ok openssl-1.0.0-20.el6_2.5.x86_64
>> > openssl-1.0.0-25.el6_3.1.x86_64
>> > curl: ok curl-7.19.7-26.el6_2.4.x86_64
>> > wget: ok wget-1.12-1.4.el6.x86_64
>> > net-snmp: ok net-snmp-5.5-41.el6.x86_64
>> > net-snmp-utils: UNAVAILABLE
>> > ntpd: UNAVAILABLE
>> > ruby: UNAVAILABLE
>> > puppet: UNAVAILABLE
>> > nagios: UNAVAILABLE
>> > ganglia: UNAVAILABLE
>> > passenger: UNAVAILABLE
>> > hadoop: UNAVAILABLE
>> > yum_repos: ok
>> >  AMBARI-1.x         Ambari 1.x
>>       6
>> > HDP-UTILS-1.1.0.15 Hortonworks Data Platform Utils Version -
>> HDP-UTILS-1.    52
>> > zypper_repos: UNAVAILABLE
>> > ', None)
>> > ('', None)
>> >
>> > STDERR
>> > Connection to localhost closed.
>> > Registering with the server...
>> > Registration with the server failed.
>>

Mime
View raw message