ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jinwei zhu <zhujinwe...@gmail.com>
Subject Re: about AMBARI-666 ambari-web not login
Date Tue, 15 Jan 2013 10:30:45 GMT
Thx, Yusaku, I have install release 1.2.0-rc0 , I have successfully created
a cluster with some hosts and services, but I can not find any page that
could delete the cluster. Is there any method to delete the cluster ?
By the way, is there some docs  (  like ambari666 docs in this wiki "
https://cwiki.apache.org/confluence/display/AMBARI/Ambari-666+Development"
)   for developers to run and to debug the code ?


2013/1/14 Yusaku Sako <yusaku@hortonworks.com>

> We will call for a vote on a 1.2.0 release candidate tomorrow (Monday).
> We will send out a link to the release branch as well as step-by-step
> instructions on how to deploy a cluster using Ambari.
> Thanks for your patience.
>
> Yusaku
>
> On Sun, Jan 13, 2013 at 7:41 PM, jinwei zhu <zhujinwei09@gmail.com> wrote:
>
> > Hi,Yusaku, I see you have committed many codes into git trunk repository
> (
> > git://git.apache.org/ambari.git) recently ,  could I use trunk code to
> run
> > ambari?  will it work?
> > By the way, this week , you will release 1.2 ,right? if yes, which day
> will
> > it release?
> >
> > Thx.
> >
> > 2013/1/11 Yusaku Sako <yusaku@hortonworks.com>
> >
> > > Hi Jinwei,
> > >
> > > The way you are making a POST call to create a cluster looks correct.
> > > A successful POST results in HTTP Status Code 201 ("Created").
> > > Note that this only creates a Cluster resource, but there are many
> other
> > > calls you would need to make in order to install a cluster (for
> example,
> > > registering hosts to the cluster, creating services and its components,
> > > assigning these components to specified hosts, creating and applying
> > > configurations to the services, initiating installation of the
> services,
> > > starting the services, etc).
> > >
> > > We are only days away from having a release candidate of Ambari 1.2.0
> > > ready.
> > > I recommend you wait for the release candidate so that you will be able
> > to
> > > try installing a cluster via Ambari Web and observe all the API calls
> it
> > > makes.
> > >
> > > Thanks!
> > > Yusaku
> > >
> > >
> > > On Thu, Jan 10, 2013 at 7:07 AM, jinwei zhu <zhujinwei09@gmail.com>
> > wrote:
> > >
> > > > HI, Yusaku,  since ambari web ui has not worked well, I am trying to
> > use
> > > > "httpclient" to send request by rest service , and the request is to
> > > create
> > > > a cluster.
> > > > Here is the java code :
> > > >         String restURL="
> http://myhostname:8080/api/clusters/mycluster"
> > > >          HttpClient client=new HttpClient();
> > > >         PostMethod postMethod = new PostMethod(restURL);
> > > >         String body="{\"hostname\":\"myhostname\"}";
> > > >         postMethod.setRequestBody(body);
> > > >         int statusCode = client.executeMethod(postMethod);
> > > >         System.out.println(postMethod.getResponseBodyAsString());
> > > >
> > > > after running this code, I try getMethod using that restURL, the rest
> > > > server could return the cluster infomation, but only a litter
> > infomation.
> > > > so ,  I doubt if the http body content is enough and if I missed some
> > > steps
> > > > before calling that restURL .   Please correct me , thanks.
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > > 2013/1/7 Yusaku Sako <yusaku@hortonworks.com>
> > > >
> > > >> Hi Peicheng,
> > > >>
> > > >> The documentation that you referred is outdated and you will not be
> > > >> able to install a cluster if you simply follow it.  Sorry about
> > > >> that...
> > > >> AMBARI-666 was a development branch for the new, unreleased 1.2.0
> > > >> version of Ambari.  The code from this branch was merged to trunk
> > > >> about a month ago.
> > > >> We will be releasing 1.2.0 shortly (in a week or so) along with
> > > >> updated documentation.
> > > >> Please try again when 1.2.0 is released.
> > > >>
> > > >> Thanks for your patience!
> > > >>
> > > >> Yusaku
> > > >>
> > > >> On Sat, Jan 5, 2013 at 6:32 AM, peicheng Liao <peicheng5@gmail.com>
> > > >> wrote:
> > > >> > Hi all:
> > > >> >
> > > >> > I try to install Ambari-666 using the docs.
> > > >> >
> > > >> > Ambari-666 Development - Apache Ambari (Incubating) - Apache
> > Software
> > > >> Foundation
> > > >> >
> > > >>
> > >
> >
> https://cwiki.apache.org/confluence/display/AMBARI/Ambari-666+Development
> > > >> >
> > > >> > I start my ambari-server , and I  can it use
> > > >> >
> > > >> > http://am1:8080/api/check
> > > >> > staus return "RUNNING"
> > > >> >
> > > >> > Next I start ambari-web ,
> > > >> >
> > > >> > #cd ambari-web
> > > >> > # brunch w
> > > >> > but not thing happend
> > > >> > so I turn on the config.coffee
> > > >> >
> > > >> > server:
> > > >> >     port: 3333
> > > >> >     base: '/'
> > > >> >     run: no
> > > >> >
> > > >> > to
> > > >> >   server:
> > > >> >     port: 3333
> > > >> >     base: '/'
> > > >> >     run: yes
> > > >> >
> > > >> > 05 Jan 09:02:16 - info: application started on
> > http://localhost:3333/
> > > >> >
> > > >> > =====
> > > >> > so I try to login the web ( user "admin" password "admin" ),
> > > >> > I found it sent request to http://am1:3333/api/v1/users/admin
> > > >> > (am1 is my server hostname,i can connect am1)
> > > >> > When I try to open the url  to check , It return
> > > >> > "Cannot GET /api/v1/users/admin "
> > > >> >
> > > >> > What kind mistake with me ?
> > > >> > Thank for your help ~
> > > >>
> > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message