ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Yang <eric...@gmail.com>
Subject Re: Unable to build project - Cannot run program python2.6
Date Tue, 17 Jan 2012 05:13:01 GMT
This is only tested on RHEL 5.x.  You might be able to make more
progress by copying python.exe to python2.6.exe.  The build system is
expecting python executable to be python2.6 to accommodate the
executable name on RHEL 5 .x.  However, Cygwin is uncharted tertiary
for Ambari.  I can't guarantee it to work, even though there shouldn't
be no technical barrier to modify Ambari to work under Cygwin.

regards,
Eric

On Mon, Jan 16, 2012 at 8:55 PM, Ahmed Fathalla <afathalla@gmail.com> wrote:
> Is there any progress on the previously suggested build process document?
>
> On Tue, Jan 17, 2012 at 12:27 AM, Ratay, Steve <Steve.Ratay@teradata.com>wrote:
>
>> I am unable to build the Ambari project.  I am running "mvn clean install"
>> from the trunk folder, and get the following error:
>>
>> [ERROR] Failed to execute goal
>> org.codehaus.mojo:exec-maven-plugin:1.2:exec (python-test) on project
>> ambari-agent: Command execution failed. Cannot run program "python2.6" (in
>> directory "D:\PROJECTS\Hadoop\ambari\trunk\agent\src\test\python"):
>> CreateProcess error=2, The system cannot find the file specified -> [Help 1]
>>
>> I am running Cygwin on a Windows 7 box.  I have installed python via
>> Cygwin, but I'm not sure what else I might need to do to get things
>> working.  I'd appreciate any help as I'm pretty much dead in the water
>> until I can get a build to complete.
>>
>> Thanks, Steve
>>
>
>
>
> --
> Ahmed Fathalla

Mime
View raw message