ambari-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jonathanhur...@apache.org
Subject [23/50] [abbrv] ambari git commit: AMBARI-21581 - Replace Hard Coded conf-select Structures (jonathanhurley)
Date Thu, 10 Aug 2017 17:49:08 GMT
http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/properties/stack_select_packages.json
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/properties/stack_select_packages.json b/ambari-server/src/main/resources/stacks/BigInsights/4.0/properties/stack_select_packages.json
deleted file mode 100644
index a91a841..0000000
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/properties/stack_select_packages.json
+++ /dev/null
@@ -1,775 +0,0 @@
-{
-  "BigInsights": {
-    "stack-select": {
-      "ATLAS": {
-        "ATLAS_CLIENT": {
-          "STACK-SELECT-PACKAGE": "atlas-client",
-          "INSTALL": [
-            "atlas-client"
-          ],
-          "PATCH": [
-            "atlas-client"
-          ],
-          "STANDARD": [
-            "atlas-client"
-          ]
-        },
-        "ATLAS_SERVER": {
-          "STACK-SELECT-PACKAGE": "atlas-server",
-          "INSTALL": [
-            "atlas-server"
-          ],
-          "PATCH": [
-            "atlas-server"
-          ],
-          "STANDARD": [
-            "atlas-server"
-          ]
-        }
-      },
-      "FLUME": {
-        "FLUME_HANDLER": {
-          "STACK-SELECT-PACKAGE": "flume-server",
-          "INSTALL": [
-            "flume-server"
-          ],
-          "PATCH": [
-            "flume-server"
-          ],
-          "STANDARD": [
-            "flume-server"
-          ]
-        }
-      },
-      "HBASE": {
-        "HBASE_CLIENT": {
-          "STACK-SELECT-PACKAGE": "hbase-client",
-          "INSTALL": [
-            "hbase-client",
-            "hadoop-client"
-          ],
-          "PATCH": [
-            "hbase-client"
-          ],
-          "STANDARD": [
-            "hbase-client",
-            "hadoop-client"
-          ]
-        },
-        "HBASE_MASTER": {
-          "STACK-SELECT-PACKAGE": "hbase-master",
-          "INSTALL": [
-            "hbase-master"
-          ],
-          "PATCH": [
-            "hbase-master"
-          ],
-          "STANDARD": [
-            "hbase-master"
-          ]
-        },
-        "HBASE_REGIONSERVER": {
-          "STACK-SELECT-PACKAGE": "hbase-regionserver",
-          "INSTALL": [
-            "hbase-regionserver"
-          ],
-          "PATCH": [
-            "hbase-regionserver"
-          ],
-          "STANDARD": [
-            "hbase-regionserver"
-          ]
-        },
-        "HBASE_REST_SERVER": {
-          "STACK-SELECT-PACKAGE": "hbase-restserver",
-          "INSTALL": [
-            "hbase-restserver"
-          ],
-          "PATCH": [
-            "hbase-restserver"
-          ],
-          "STANDARD": [
-            "hbase-restserver"
-          ]
-        },
-
-        "PHOENIX_QUERY_SERVER": {
-          "STACK-SELECT-PACKAGE": "phoenix-server",
-          "INSTALL": [
-            "phoenix-server"
-          ],
-          "PATCH": [
-            "phoenix-server"
-          ],
-          "STANDARD": [
-            "phoenix-server"
-          ]
-        }
-      },
-      "HDFS": {
-        "DATANODE": {
-          "STACK-SELECT-PACKAGE": "hadoop-hdfs-datanode",
-          "INSTALL": [
-            "hadoop-hdfs-datanode"
-          ],
-          "PATCH": [
-            "hadoop-hdfs-datanode"
-          ],
-          "STANDARD": [
-            "hadoop-hdfs-datanode"
-          ]
-        },
-        "HDFS_CLIENT": {
-          "STACK-SELECT-PACKAGE": "hadoop-client",
-          "INSTALL": [
-            "hadoop-client"
-          ],
-          "PATCH": [
-            "hadoop-client"
-          ],
-          "STANDARD": [
-            "hadoop-client"
-          ]
-        },
-        "NAMENODE": {
-          "STACK-SELECT-PACKAGE": "hadoop-hdfs-namenode",
-          "INSTALL": [
-            "hadoop-hdfs-namenode"
-          ],
-          "PATCH": [
-            "hadoop-hdfs-namenode"
-          ],
-          "STANDARD": [
-            "hadoop-hdfs-namenode"
-          ]
-        },
-        "NFS_GATEWAY": {
-          "STACK-SELECT-PACKAGE": "hadoop-hdfs-nfs3",
-          "INSTALL": [
-            "hadoop-hdfs-nfs3"
-          ],
-          "PATCH": [
-            "hadoop-hdfs-nfs3"
-          ],
-          "STANDARD": [
-            "hadoop-hdfs-nfs3"
-          ]
-        },
-        "JOURNALNODE": {
-          "STACK-SELECT-PACKAGE": "hadoop-hdfs-journalnode",
-          "INSTALL": [
-            "hadoop-hdfs-journalnode"
-          ],
-          "PATCH": [
-            "hadoop-hdfs-journalnode"
-          ],
-          "STANDARD": [
-            "hadoop-hdfs-journalnode"
-          ]
-        },
-        "SECONDARY_NAMENODE": {
-          "STACK-SELECT-PACKAGE": "hadoop-hdfs-secondarynamenode",
-          "INSTALL": [
-            "hadoop-hdfs-secondarynamenode"
-          ],
-          "PATCH": [
-            "hadoop-hdfs-secondarynamenode"
-          ],
-          "STANDARD": [
-            "hadoop-hdfs-secondarynamenode"
-          ]
-        },
-        "ZKFC": {
-          "STACK-SELECT-PACKAGE": "hadoop-hdfs-zkfc",
-          "INSTALL": [
-            "hadoop-hdfs-zkfc"
-          ],
-          "PATCH": [
-            "hadoop-hdfs-zkfc"
-          ],
-          "STANDARD": [
-            "hadoop-hdfs-zkfc"
-          ]
-        }
-      },
-      "HIVE": {
-        "HCAT": {
-          "STACK-SELECT-PACKAGE": "hive-webhcat",
-          "INSTALL": [
-            "hive-webhcat"
-          ],
-          "PATCH": [
-            "hive-webhcat"
-          ],
-          "STANDARD": [
-            "hive-webhcat"
-          ]
-        },
-        "HIVE_METASTORE": {
-          "STACK-SELECT-PACKAGE": "hive-metastore",
-          "INSTALL": [
-            "hive-metastore"
-          ],
-          "PATCH": [
-            "hive-metastore"
-          ],
-          "STANDARD": [
-            "hive-metastore"
-          ]
-        },
-        "HIVE_SERVER": {
-          "STACK-SELECT-PACKAGE": "hive-server2",
-          "INSTALL": [
-            "hive-server2"
-          ],
-          "PATCH": [
-            "hive-server2"
-          ],
-          "STANDARD": [
-            "hive-server2"
-          ]
-        },
-        "HIVE_SERVER_INTERACTIVE": {
-          "STACK-SELECT-PACKAGE": "hive-server2-hive2",
-          "INSTALL": [
-            "hive-server2-hive2"
-          ],
-          "PATCH": [
-            "hive-server2-hive2"
-          ],
-          "STANDARD": [
-            "hive-server2-hive2"
-          ]
-        },
-        "HIVE_CLIENT": {
-          "STACK-SELECT-PACKAGE": "hadoop-client",
-          "INSTALL": [
-            "hadoop-client"
-          ],
-          "PATCH": [
-            "hadoop-client"
-          ],
-          "STANDARD": [
-            "hadoop-client"
-          ]
-        },
-        "WEBHCAT_SERVER": {
-          "STACK-SELECT-PACKAGE": "hive-webhcat",
-          "INSTALL": [
-            "hive-webhcat"
-          ],
-          "PATCH": [
-            "hive-webhcat"
-          ],
-          "STANDARD": [
-            "hive-webhcat"
-          ]
-        }
-      },
-      "KAFKA": {
-        "KAFKA_BROKER": {
-          "STACK-SELECT-PACKAGE": "kafka-broker",
-          "INSTALL": [
-            "kafka-broker"
-          ],
-          "PATCH": [
-            "kafka-broker"
-          ],
-          "STANDARD": [
-            "kafka-broker"
-          ]
-        }
-      },
-      "KNOX": {
-        "KNOX_GATEWAY": {
-          "STACK-SELECT-PACKAGE": "knox-server",
-          "INSTALL": [
-            "knox-server"
-          ],
-          "PATCH": [
-            "knox-server"
-          ],
-          "STANDARD": [
-            "knox-server"
-          ]
-        }
-      },
-      "MAPREDUCE2": {
-        "HISTORYSERVER": {
-          "STACK-SELECT-PACKAGE": "hadoop-mapreduce-historyserver",
-          "INSTALL": [
-            "hadoop-mapreduce-historyserver"
-          ],
-          "PATCH": [
-            "hadoop-mapreduce-historyserver"
-          ],
-          "STANDARD": [
-            "hadoop-mapreduce-historyserver"
-          ]
-        },
-        "MAPREDUCE2_CLIENT": {
-          "STACK-SELECT-PACKAGE": "hadoop-client",
-          "INSTALL": [
-            "hadoop-client"
-          ],
-          "PATCH": [
-            "hadoop-client"
-          ],
-          "STANDARD": [
-            "hadoop-client"
-          ]
-        }
-      },
-      "OOZIE": {
-        "OOZIE_CLIENT": {
-          "STACK-SELECT-PACKAGE": "oozie-client",
-          "INSTALL": [
-            "oozie-client"
-          ],
-          "PATCH": [
-            "oozie-client"
-          ],
-          "STANDARD": [
-            "oozie-client"
-          ]
-        },
-        "OOZIE_SERVER": {
-          "STACK-SELECT-PACKAGE": "oozie-server",
-          "INSTALL": [
-            "oozie-client",
-            "oozie-server"
-          ],
-          "PATCH": [
-            "oozie-server"
-          ],
-          "STANDARD": [
-            "oozie-client",
-            "oozie-server"
-          ]
-        }
-      },
-      "PIG": {
-        "PIG": {
-          "STACK-SELECT-PACKAGE": "hadoop-client",
-          "INSTALL": [
-            "hadoop-client"
-          ],
-          "PATCH": [
-            "hadoop-client"
-          ],
-          "STANDARD": [
-            "hadoop-client"
-          ]
-        }
-      },
-      "R4ML": {
-        "R4ML": {
-          "STACK-SELECT-PACKAGE": "r4ml-client",
-          "INSTALL": [
-            "r4ml-client"
-          ],
-          "PATCH": [
-            "r4ml-client"
-          ],
-          "STANDARD": [
-            "r4ml-client"
-          ]
-        }
-      },
-      "RANGER": {
-        "RANGER_ADMIN": {
-          "STACK-SELECT-PACKAGE": "ranger-admin",
-          "INSTALL": [
-            "ranger-admin"
-          ],
-          "PATCH": [
-            "ranger-admin"
-          ],
-          "STANDARD": [
-            "ranger-admin"
-          ]
-        },
-        "RANGER_TAGSYNC": {
-          "STACK-SELECT-PACKAGE": "ranger-tagsync",
-          "INSTALL": [
-            "ranger-tagsync"
-          ],
-          "PATCH": [
-            "ranger-tagsync"
-          ],
-          "STANDARD": [
-            "ranger-tagsync"
-          ]
-        },
-        "RANGER_USERSYNC": {
-          "STACK-SELECT-PACKAGE": "ranger-usersync",
-          "INSTALL": [
-            "ranger-usersync"
-          ],
-          "PATCH": [
-            "ranger-usersync"
-          ],
-          "STANDARD": [
-            "ranger-usersync"
-          ]
-        }
-      },
-      "RANGER_KMS": {
-        "RANGER_KMS_SERVER": {
-          "STACK-SELECT-PACKAGE": "ranger-kms",
-          "INSTALL": [
-            "ranger-kms"
-          ],
-          "PATCH": [
-            "ranger-kms"
-          ],
-          "STANDARD": [
-            "ranger-kms"
-          ]
-        }
-      },
-      "SLIDER": {
-        "SLIDER": {
-          "STACK-SELECT-PACKAGE": "slider-client",
-          "INSTALL": [
-            "slider-client",
-            "hadoop-client"
-          ],
-          "PATCH": [
-            "slider-client"
-          ],
-          "STANDARD": [
-            "slider-client",
-            "hadoop-client"
-          ]
-        }
-      },
-      "SOLR": {
-        "SOLR": {
-          "STACK-SELECT-PACKAGE": "solr-server",
-          "INSTALL": [
-            "solr-server"
-          ],
-          "PATCH": [
-            "solr-server"
-          ],
-          "STANDARD": [
-            "solr-server"
-          ]
-        }
-      },
-      "SPARK": {
-        "LIVY_SERVER": {
-          "STACK-SELECT-PACKAGE": "livy-server",
-          "INSTALL": [
-            "livy-server"
-          ],
-          "PATCH": [
-            "livy-server"
-          ],
-          "STANDARD": [
-            "livy-server"
-          ]
-        },
-        "SPARK_CLIENT": {
-          "STACK-SELECT-PACKAGE": "spark-client",
-          "INSTALL": [
-            "spark-client"
-          ],
-          "PATCH": [
-            "spark-client"
-          ],
-          "STANDARD": [
-            "spark-client"
-          ]
-        },
-        "SPARK_JOBHISTORYSERVER": {
-          "STACK-SELECT-PACKAGE": "spark-historyserver",
-          "INSTALL": [
-            "spark-historyserver"
-          ],
-          "PATCH": [
-            "spark-historyserver"
-          ],
-          "STANDARD": [
-            "spark-historyserver"
-          ]
-        },
-        "SPARK_THRIFTSERVER": {
-          "STACK-SELECT-PACKAGE": "spark-thriftserver",
-          "INSTALL": [
-            "spark-thriftserver"
-          ],
-          "PATCH": [
-            "spark-thriftserver"
-          ],
-          "STANDARD": [
-            "spark-thriftserver"
-          ]
-        }
-      },
-      "SPARK2": {
-        "LIVY2_SERVER": {
-          "STACK-SELECT-PACKAGE": "livy2-server",
-          "INSTALL": [
-            "livy2-server"
-          ],
-          "PATCH": [
-            "livy2-server"
-          ],
-          "STANDARD": [
-            "livy2-server"
-          ]
-        },
-        "SPARK2_CLIENT": {
-          "STACK-SELECT-PACKAGE": "spark2-client",
-          "INSTALL": [
-            "spark2-client"
-          ],
-          "PATCH": [
-            "spark2-client"
-          ],
-          "STANDARD": [
-            "spark2-client"
-          ]
-        },
-        "SPARK2_JOBHISTORYSERVER": {
-          "STACK-SELECT-PACKAGE": "spark2-historyserver",
-          "INSTALL": [
-            "spark2-historyserver"
-          ],
-          "PATCH": [
-            "spark2-historyserver"
-          ],
-          "STANDARD": [
-            "spark2-historyserver"
-          ]
-        },
-        "SPARK2_THRIFTSERVER": {
-          "STACK-SELECT-PACKAGE": "spark2-thriftserver",
-          "INSTALL": [
-            "spark2-thriftserver"
-          ],
-          "PATCH": [
-            "spark2-thriftserver"
-          ],
-          "STANDARD": [
-            "spark2-thriftserver"
-          ]
-        }
-      },
-      "SQOOP": {
-        "SQOOP": {
-          "STACK-SELECT-PACKAGE": "sqoop-client",
-          "INSTALL": [
-            "sqoop-client"
-          ],
-          "PATCH": [
-            "sqoop-client"
-          ],
-          "STANDARD": [
-            "sqoop-client"
-          ]
-        }
-      },
-      "STORM": {
-        "NIMBUS": {
-          "STACK-SELECT-PACKAGE": "storm-nimbus",
-          "INSTALL": [
-            "storm-client",
-            "storm-nimbus"
-          ],
-          "PATCH": [
-            "storm-client",
-            "storm-nimbus"
-          ],
-          "STANDARD": [
-            "storm-client",
-            "storm-nimbus"
-          ]
-        },
-        "SUPERVISOR": {
-          "STACK-SELECT-PACKAGE": "storm-supervisor",
-          "INSTALL": [
-            "storm-supervisor"
-          ],
-          "PATCH": [
-            "storm-supervisor"
-          ],
-          "STANDARD": [
-            "storm-client",
-            "storm-supervisor"
-          ]
-        },
-        "DRPC_SERVER": {
-          "STACK-SELECT-PACKAGE": "storm-client",
-          "INSTALL": [
-            "storm-client"
-          ],
-          "PATCH": [
-            "storm-client"
-          ],
-          "STANDARD": [
-            "storm-client"
-          ]
-        },
-        "STORM_UI_SERVER": {
-          "STACK-SELECT-PACKAGE": "storm-client",
-          "INSTALL": [
-            "storm-client"
-          ],
-          "PATCH": [
-            "storm-client"
-          ],
-          "STANDARD": [
-            "storm-client"
-          ]
-        }
-      },
-      "SYSTEMML": {
-        "SYSTEMML": {
-          "STACK-SELECT-PACKAGE": "systemml-client",
-          "INSTALL": [
-            "systemml-client"
-          ],
-          "PATCH": [
-            "systemml-client"
-          ],
-          "STANDARD": [
-            "systemml-client"
-          ]
-        }
-      },
-      "TEZ": {
-        "TEZ_CLIENT": {
-          "STACK-SELECT-PACKAGE": "hadoop-client",
-          "INSTALL": [
-            "hadoop-client"
-          ],
-          "PATCH": [
-            "hadoop-client"
-          ],
-          "STANDARD": [
-            "hadoop-client"
-          ]
-        }
-      },
-      "TITAN": {
-        "TITAN_CLIENT": {
-          "STACK-SELECT-PACKAGE": "titan-client",
-          "INSTALL": [
-            "titan-client"
-          ],
-          "PATCH": [
-            "titan-client"
-          ],
-          "STANDARD": [
-            "titan-client"
-          ]
-        },
-        "TITAN_SERVER": {
-          "STACK-SELECT-PACKAGE": "titan-server",
-          "INSTALL": [
-            "titan-server"
-          ],
-          "PATCH": [
-            "titan-server"
-          ],
-          "STANDARD": [
-            "titan-server"
-          ]
-        }
-      },
-      "YARN": {
-        "APP_TIMELINE_SERVER": {
-          "STACK-SELECT-PACKAGE": "hadoop-yarn-timelineserver",
-          "INSTALL": [
-            "hadoop-yarn-timelineserver"
-          ],
-          "PATCH": [
-            "hadoop-yarn-timelineserver"
-          ],
-          "STANDARD": [
-            "hadoop-yarn-timelineserver"
-          ]
-        },
-        "NODEMANAGER": {
-          "STACK-SELECT-PACKAGE": "hadoop-yarn-nodemanager",
-          "INSTALL": [
-            "hadoop-yarn-nodemanager"
-          ],
-          "PATCH": [
-            "hadoop-yarn-nodemanager"
-          ],
-          "STANDARD": [
-            "hadoop-yarn-nodemanager"
-          ]
-        },
-        "RESOURCEMANAGER": {
-          "STACK-SELECT-PACKAGE": "hadoop-yarn-resourcemanager",
-          "INSTALL": [
-            "hadoop-yarn-resourcemanager"
-          ],
-          "PATCH": [
-            "hadoop-yarn-resourcemanager"
-          ],
-          "STANDARD": [
-            "hadoop-yarn-resourcemanager"
-          ]
-        },
-        "YARN_CLIENT": {
-          "STACK-SELECT-PACKAGE": "hadoop-client",
-          "INSTALL": [
-            "hadoop-client"
-          ],
-          "PATCH": [
-            "hadoop-client"
-          ],
-          "STANDARD": [
-            "hadoop-client"
-          ]
-        }
-      },
-      "ZEPPELIN": {
-        "ZEPPELIN_MASTER": {
-          "STACK-SELECT-PACKAGE": "zeppelin-server",
-          "INSTALL": [
-            "zeppelin-server"
-          ],
-          "PATCH": [
-            "zeppelin-server"
-          ],
-          "STANDARD": [
-            "zeppelin-server"
-          ]
-        }
-      },
-      "ZOOKEEPER": {
-        "ZOOKEEPER_CLIENT": {
-          "STACK-SELECT-PACKAGE": "zookeeper-client",
-          "INSTALL": [
-            "zookeeper-client"
-          ],
-          "PATCH": [
-            "zookeeper-client"
-          ],
-          "STANDARD": [
-            "zookeeper-client"
-          ]
-        },
-        "ZOOKEEPER_SERVER": {
-          "STACK-SELECT-PACKAGE": "zookeeper-server",
-          "INSTALL": [
-            "zookeeper-server"
-          ],
-          "PATCH": [
-            "zookeeper-server"
-          ],
-          "STANDARD": [
-            "zookeeper-server"
-          ]
-        }
-      }
-    }
-  }
-}
\ No newline at end of file

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/FLUME/package/scripts/flume_handler.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/FLUME/package/scripts/flume_handler.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/FLUME/package/scripts/flume_handler.py
index 159278a..86a1468 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/FLUME/package/scripts/flume_handler.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/FLUME/package/scripts/flume_handler.py
@@ -23,7 +23,6 @@ from flume import flume
 from flume import get_desired_state
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.flume_agent_helper import find_expected_agent_names
 from resource_management.libraries.functions.flume_agent_helper import get_flume_status
@@ -133,7 +132,6 @@ class FlumeHandler(Script):
       return
 
     Logger.info("Executing Flume Stack Upgrade pre-restart")
-    conf_select.select(params.stack_name, "flume", params.version)
     stack_select.select_packages(params.version)
     if params.upgrade_direction == Direction.UPGRADE:
       flume_upgrade.pre_start_restore()

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/hbase_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/hbase_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/hbase_client.py
index df382ce..43a1709 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/hbase_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/hbase_client.py
@@ -20,7 +20,6 @@ limitations under the License.
 
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 
 from hbase import hbase
@@ -33,15 +32,7 @@ class HbaseClient(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hbase", params.version)
       stack_select.select_packages(params.version)
-      #Execute(format("stack-select set hbase-client {version}"))
-
-      # set all of the hadoop clientss since hbase client is upgraded as part
-      # of the final "CLIENTS" group and we need to ensure that hadoop-client
-      # is also set
-      conf_select.select(params.stack_name, "hadoop", params.version)
-      #Execute(format("stack-select set hadoop-client {version}"))
 
   def install(self, env):
     self.install_packages(env)

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/upgrade.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/upgrade.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/upgrade.py
index f1024c5..c812a54 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/upgrade.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HBASE/package/scripts/upgrade.py
@@ -21,7 +21,6 @@ limitations under the License.
 from resource_management import *
 from resource_management.core.resources.system import Execute
 from resource_management.core import shell
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.libraries.functions.decorator import retry
@@ -30,7 +29,6 @@ def prestart(env):
   import params
 
   if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-    conf_select.select(params.stack_name, "hbase", params.version)
     stack_select.select_packages(params.version)
 
 def post_regionserver(env):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/datanode.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/datanode.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/datanode.py
index b1f1d00..3570bf7 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/datanode.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/datanode.py
@@ -18,7 +18,6 @@ limitations under the License.
 """
 import datanode_upgrade
 from hdfs_datanode import datanode
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management import *
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
@@ -66,7 +65,6 @@ class DataNode(Script):
     import params
     env.set_params(params)
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set hadoop-hdfs-datanode {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/hdfs_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/hdfs_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/hdfs_client.py
index 851afd6..d6e4ce9 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/hdfs_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/hdfs_client.py
@@ -18,7 +18,6 @@ limitations under the License.
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.security_commons import build_expectations, \
   cached_kinit_executor, get_params_from_filesystem, validate_security_config_properties, \
@@ -40,7 +39,6 @@ class HdfsClient(Script):
     import params
     env.set_params(params)
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
 
   def start(self, env, upgrade_type=False):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/journalnode.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/journalnode.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/journalnode.py
index afc54be..778fbb7 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/journalnode.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/journalnode.py
@@ -18,7 +18,6 @@ limitations under the License.
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, \
   format_stack_version
@@ -46,7 +45,6 @@ class JournalNode(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set hadoop-hdfs-journalnode {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/namenode.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/namenode.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/namenode.py
index 38ad927..8fcf310 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/namenode.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/namenode.py
@@ -22,7 +22,6 @@ import os
 import json
 import  tempfile
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.security_commons import build_expectations, \
   cached_kinit_executor, get_params_from_filesystem, validate_security_config_properties, \
@@ -84,7 +83,6 @@ class NameNode(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set hadoop-hdfs-namenode {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/nfsgateway.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/nfsgateway.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/nfsgateway.py
index 8edd037..2330a84 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/nfsgateway.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/nfsgateway.py
@@ -24,7 +24,6 @@ from resource_management.libraries.functions.security_commons import build_expec
   FILE_TYPE_XML
 from hdfs_nfsgateway import nfsgateway
 from hdfs import hdfs
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 
@@ -43,7 +42,6 @@ class NFSGateway(Script):
     env.set_params(params)
 
     if Script.is_stack_greater_or_equal('4.1.0.0'):
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
 
   def start(self, env, upgrade_type=None):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/snamenode.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/snamenode.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/snamenode.py
index 1fe89a2..1de54f3 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/snamenode.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HDFS/package/scripts/snamenode.py
@@ -18,7 +18,6 @@ limitations under the License.
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.libraries.functions.security_commons import build_expectations, \
@@ -44,7 +43,6 @@ class SNameNode(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
 
   def start(self, env, upgrade_type=None):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_client.py
index 5ec624c..b2548c9 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_client.py
@@ -19,7 +19,6 @@ limitations under the License.
 """
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from hive import hive
 from ambari_commons.os_family_impl import OsFamilyImpl
@@ -47,8 +46,6 @@ class HiveClientDefault(HiveClient):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.1.0.0') >= 0:
-      conf_select.select(params.stack_name, "hive", params.version)
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
 
   def pre_upgrade_restart(self, env, upgrade_type=None):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_metastore.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_metastore.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_metastore.py
index 8fcd4e4..88bb2e0 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_metastore.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_metastore.py
@@ -22,7 +22,6 @@ import os
 from resource_management.core.logger import Logger
 from resource_management.core.resources.system import Execute
 from resource_management.libraries.script import Script
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.format import format
 from resource_management.libraries.functions.version import format_stack_version
@@ -85,7 +84,6 @@ class HiveMetastoreDefault(HiveMetastore):
       self.upgrade_schema(env)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hive", params.version)
       stack_select.select_packages(params.version)
 
   def security_status(self, env):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_server.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_server.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_server.py
index 269e8978..64b97cc 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_server.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_server.py
@@ -21,7 +21,6 @@ limitations under the License.
 
 from resource_management.libraries.script.script import Script
 from resource_management.libraries.resources.hdfs_resource import HdfsResource
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions import format
 from resource_management.libraries.functions.copy_tarball import copy_to_hdfs
@@ -91,7 +90,6 @@ class HiveServerDefault(HiveServer):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hive", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set hive-server2 {version}"))
       resource_created = copy_to_hdfs("mapreduce", params.user_group, params.hdfs_user)

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/webhcat_server.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/webhcat_server.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/webhcat_server.py
index 627c96e..6a2f0b1 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/webhcat_server.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/webhcat_server.py
@@ -19,7 +19,6 @@ Ambari Agent
 
 """
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.security_commons import build_expectations, \
   cached_kinit_executor, get_params_from_filesystem, validate_security_config_properties, \
@@ -66,7 +65,6 @@ class WebHCatServerDefault(WebHCatServer):
 
     if params.version and compare_versions(format_stack_version(params.version), '4.1.0.0') >= 0:
       # webhcat has no conf, but uses hadoop home, so verify that regular hadoop conf is set
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
 
   def security_status(self, env):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/kafka_broker.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/kafka_broker.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/kafka_broker.py
index 9fad6a7..cb5954e 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/kafka_broker.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/kafka_broker.py
@@ -18,7 +18,6 @@ limitations under the License.
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions import Direction
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
@@ -56,9 +55,6 @@ class KafkaBroker(Script):
     if params.version and compare_versions(format_stack_version(params.version), '4.1.0.0') >= 0:
       stack_select.select_packages(params.version)
 
-    if params.version and compare_versions(format_stack_version(params.version), '4.1.0.0') >= 0:
-      conf_select.select(params.stack_name, "kafka", params.version)
-
     # This is extremely important since it should only be called if crossing the IOP 4.2 boundary.
     if params.current_version and params.version and params.upgrade_direction:
       src_version = dst_version = None

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/upgrade.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/upgrade.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/upgrade.py
index 5628297..ba6396e 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/upgrade.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/upgrade.py
@@ -22,7 +22,6 @@ import os
 
 from resource_management import *
 from resource_management.core.resources.system import Execute
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.libraries.functions import format
@@ -84,5 +83,4 @@ def prestart(env):
   import params
 
   if params.version and compare_versions(format_stack_version(params.version), '4.1.0.0') >= 0:
-    conf_select.select(params.stack_name, "kafka", params.version)
     stack_select.select_packages(params.version)

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KNOX/package/scripts/knox_gateway.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KNOX/package/scripts/knox_gateway.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KNOX/package/scripts/knox_gateway.py
index 99e0086..c0fdd33 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KNOX/package/scripts/knox_gateway.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KNOX/package/scripts/knox_gateway.py
@@ -18,7 +18,6 @@ limitations under the License.
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 import os
 import tarfile
 
@@ -110,7 +109,6 @@ class KnoxGateway(Script):
         absolute_backup_dir = upgrade.backup_data()
 
       # conf-select will change the symlink to the conf folder.
-      conf_select.select(params.stack_name, "knox", params.version)
       stack_select.select_packages(params.version)
 
       # Extract the tar of the old conf folder into the new conf directory

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_client.py
index a7a205b..f9fc61a 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_client.py
@@ -20,7 +20,6 @@ limitations under the License.
 
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 
 from oozie import oozie
@@ -54,7 +53,6 @@ class OozieClient(Script):
       return
 
     Logger.info("Executing Oozie Client Rolling Upgrade pre-restart")
-    conf_select.select(params.stack_name, "oozie", params.version)
     stack_select.select_packages(params.version)
     #Execute(format("stack-select set oozie-client {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_server.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_server.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_server.py
index 11c8c8e..4243622 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_server.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/OOZIE/package/scripts/oozie_server.py
@@ -23,7 +23,6 @@ import oozie_server_upgrade
 from resource_management.core import Logger
 from resource_management.core.resources.system import Execute
 from resource_management.libraries.functions import format
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.constants import Direction
 from resource_management.libraries.script import Script
@@ -52,7 +51,6 @@ class OozieServer(Script):
     #TODO: needed?
     if upgrade_type == "nonrolling" and params.upgrade_direction == Direction.UPGRADE and \
             params.version and compare_versions(format_stack_version(params.version), '4.1.0.0') >= 0:
-      conf_select.select(params.stack_name, "oozie", params.version)
       # In order for the "/usr/hdp/current/oozie-<client/server>" point to the new version of
       # oozie, we need to create the symlinks both for server and client.
       # This is required as both need to be pointing to new installed oozie version.
@@ -176,7 +174,6 @@ class OozieServer(Script):
 
     oozie_server_upgrade.backup_configuration()
 
-    conf_select.select(params.stack_name, "oozie", params.version)
     stack_select.select_packages(params.version)
     #Execute(format("stack-select set oozie-server {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/PIG/package/scripts/pig_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/PIG/package/scripts/pig_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/PIG/package/scripts/pig_client.py
index 96a48c1..65403a1 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/PIG/package/scripts/pig_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/PIG/package/scripts/pig_client.py
@@ -22,7 +22,6 @@ Ambari Agent
 import sys
 import os
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from pig import pig
 
@@ -44,8 +43,6 @@ class PigClientLinux(PigClient):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "pig", params.version)
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
 
   def install(self, env):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SLIDER/package/scripts/slider_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SLIDER/package/scripts/slider_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SLIDER/package/scripts/slider_client.py
index e5c1483..0646165 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SLIDER/package/scripts/slider_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SLIDER/package/scripts/slider_client.py
@@ -19,7 +19,6 @@ limitations under the License.
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from slider import slider
 
@@ -31,15 +30,7 @@ class SliderClient(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "slider", params.version)
       stack_select.select_packages(params.version)
-      #Execute(format("stack-select set slider-client {version}"))
-
-      # also set all of the hadoop clients since slider client is upgraded as
-      # part of the final "CLIENTS" group and we need to ensure that
-      # hadoop-client is also set
-      conf_select.select(params.stack_name, "hadoop", params.version)
-      #Execute(format("stack-select set hadoop-client {version}"))
 
   def install(self, env):
     self.install_packages(env)

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_server.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_server.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_server.py
index 3605264..62cd26d 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_server.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_server.py
@@ -20,7 +20,6 @@ limitations under the License.
 
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import Direction
 from resource_management.libraries.functions import stack_select
 from solr_service import solr_service
@@ -45,14 +44,6 @@ class SolrServer(Script):
     if params.version and compare_versions(format_stack_version(params.version), '4.1.0.0') >= 0:
       stack_select.select_packages(params.version)
 
-      call_conf_select = True
-      conf_dir = '/usr/iop/4.1.0.0/solr/conf'
-      if params.upgrade_direction is not None and params.upgrade_direction == Direction.DOWNGRADE and not os.path.islink(conf_dir):
-        call_conf_select = False
-
-      if call_conf_select:
-        conf_select.select(params.stack_name, "solr", params.version)
-
   def start(self, env, upgrade_type=None):
     import params
     env.set_params(params)

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_upgrade.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_upgrade.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_upgrade.py
index d72c5a3..fa2feb0 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_upgrade.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_upgrade.py
@@ -65,8 +65,6 @@ class SolrServerUpgrade(Script):
            to=solr41_etc_dir
       )
 
-    conf_select.select(params.stack_name, "solr", "4.1.0.0")
-
   def pre_stop_backup_cores(self, env):
     """
     Backs up the Solr cores under Solr's home directory.

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/job_history_server.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/job_history_server.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/job_history_server.py
index 654b88a..abc79fe 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/job_history_server.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/job_history_server.py
@@ -21,7 +21,6 @@ limitations under the License.
 import sys
 import os
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 #from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.core.exceptions import ComponentIsNotRunning
@@ -37,7 +36,6 @@ class JobHistoryServer(Script):
 
     env.set_params(params)
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "spark", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set spark-historyserver {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_client.py
index 7f2e7fc..29320ed 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_client.py
@@ -20,7 +20,6 @@ limitations under the License.
 
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 #from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.core.exceptions import ComponentIsNotRunning
@@ -36,7 +35,6 @@ class SparkClient(Script):
 
     env.set_params(params)
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "spark", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set spark-client {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_thrift_server.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_thrift_server.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_thrift_server.py
index 75908a7..a680312 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_thrift_server.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SPARK/package/scripts/spark_thrift_server.py
@@ -23,7 +23,6 @@ import socket
 import os
 from resource_management import *
 from resource_management.libraries.functions import stack_select
-from resource_management.libraries.functions import conf_select
 from resource_management.core.exceptions import ComponentIsNotRunning
 from resource_management.core.logger import Logger
 from resource_management.core import shell
@@ -38,7 +37,6 @@ class ThriftServer(Script):
 
     env.set_params(params)
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "spark", params.version)
       stack_select.select_packages(params.version)
 
   def install(self, env):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SQOOP/package/scripts/sqoop_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SQOOP/package/scripts/sqoop_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SQOOP/package/scripts/sqoop_client.py
index 5e48aca..2382980 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SQOOP/package/scripts/sqoop_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SQOOP/package/scripts/sqoop_client.py
@@ -20,7 +20,6 @@ limitations under the License.
 
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 
@@ -34,7 +33,6 @@ class SqoopClient(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "sqoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set sqoop-client {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/application_timeline_server.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/application_timeline_server.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/application_timeline_server.py
index 125a65f..5f194c5 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/application_timeline_server.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/application_timeline_server.py
@@ -20,7 +20,6 @@ Ambari Agent
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.libraries.functions.security_commons import build_expectations, \
@@ -48,7 +47,6 @@ class ApplicationTimelineServer(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set hadoop-yarn-timelineserver {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/historyserver.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/historyserver.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/historyserver.py
index d887fce..6198342 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/historyserver.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/historyserver.py
@@ -21,7 +21,6 @@ Ambari Agent
 
 from resource_management.libraries.script.script import Script
 from resource_management.libraries.resources.hdfs_resource import HdfsResource
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.check_process_status import check_process_status
 from resource_management.libraries.functions.copy_tarball import copy_to_hdfs
@@ -55,7 +54,6 @@ class HistoryServer(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       # MC Hammer said, "Can't touch this"
       copy_to_hdfs("mapreduce", params.user_group, params.hdfs_user, skip=params.host_sys_prepped)

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/mapreduce2_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/mapreduce2_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/mapreduce2_client.py
index fe64193..35efdfc 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/mapreduce2_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/mapreduce2_client.py
@@ -21,7 +21,6 @@ Ambari Agent
 
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 
 from yarn import yarn
@@ -33,7 +32,6 @@ class MapReduce2Client(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set hadoop-client {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/nodemanager.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/nodemanager.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/nodemanager.py
index c048127..4a5263d 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/nodemanager.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/nodemanager.py
@@ -22,7 +22,6 @@ Ambari Agent
 import nodemanager_upgrade
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.libraries.functions.format import format
@@ -49,7 +48,6 @@ class Nodemanager(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set hadoop-yarn-nodemanager {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/resourcemanager.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/resourcemanager.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/resourcemanager.py
index 554c23d..db4ee72 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/resourcemanager.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/resourcemanager.py
@@ -20,7 +20,6 @@ Ambari Agent
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.libraries.functions.security_commons import build_expectations, \
@@ -48,7 +47,6 @@ class Resourcemanager(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set hadoop-yarn-resourcemanager {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/yarn_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/yarn_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/yarn_client.py
index 1f139bf..23713b0 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/yarn_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/YARN/package/scripts/yarn_client.py
@@ -45,7 +45,6 @@ class YarnClient(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set hadoop-client {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_client.py
index 63e1df8..63b1b46 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_client.py
@@ -21,7 +21,6 @@ Ambari Agent
 
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.libraries.functions.format import format
@@ -46,7 +45,6 @@ class ZookeeperClient(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "zookeeper", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set zookeeper-client {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_server.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_server.py b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_server.py
index 727622a..28dc15b 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_server.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_server.py
@@ -22,7 +22,6 @@ import random
 
 from resource_management.libraries.script.script import Script
 from resource_management.libraries.functions import get_unique_id_and_date
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.libraries.functions.security_commons import build_expectations, \
@@ -55,7 +54,6 @@ class ZookeeperServer(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "zookeeper", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("stack-select set zookeeper-server {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/hook.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/hook.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/hook.py
index 8a583b3..8bae9e6 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/hook.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/hook.py
@@ -28,7 +28,7 @@ class AfterInstallHook(Hook):
     import params
 
     env.set_params(params)
-    setup_stack_symlinks()
+    setup_stack_symlinks(self.stroutfile)
     setup_config()
 
     link_configs(self.stroutfile)

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/shared_initialization.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/shared_initialization.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/shared_initialization.py
index 1324c8c..4b9f6cf 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/shared_initialization.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/shared_initialization.py
@@ -29,7 +29,7 @@ from resource_management.libraries.resources.xml_config import XmlConfig
 from resource_management.libraries.script import Script
 
 
-def setup_stack_symlinks():
+def setup_stack_symlinks(struct_out_file):
   """
   Invokes <stack-selector-tool> set all against a calculated fully-qualified, "normalized" version based on a
   stack version, such as "4.1". This should always be called after a component has been
@@ -38,25 +38,26 @@ def setup_stack_symlinks():
   :return:
   """
   import params
-  if params.stack_version_formatted != "" and compare_versions(params.stack_version_formatted, '4.0') >= 0:
-    # try using the exact version first, falling back in just the stack if it's not defined
-    # which would only be during an intial cluster installation
-    version = params.current_version if params.current_version is not None else params.stack_version_unformatted
-
-    if params.upgrade_suspended:
-      Logger.warning(
-        "Skipping running stack-selector-tool for stack {0} because there is a suspended upgrade")
-      return
-
-    # get the packages which the stack-select tool should be used on
-    stack_select_packages = stack_select.get_packages(stack_select.PACKAGE_SCOPE_INSTALL)
-    if stack_select_packages is None:
-      return
-
-    # On parallel command execution this should be executed by a single process at a time.
-    with FcntlBasedProcessLock(params.stack_select_lock_file, enabled = params.is_parallel_execution_enabled, skip_fcntl_failures = True):
-      for package in stack_select_packages:
-        stack_select.select(package, version)
+  if params.upgrade_suspended:
+    Logger.warning("Skipping running stack-selector-tool because there is a suspended upgrade")
+    return
+
+  # get the packages which the stack-select tool should be used on
+  stack_packages = stack_select.get_packages(stack_select.PACKAGE_SCOPE_INSTALL)
+  if stack_packages is None:
+    return
+
+  json_version = load_version(struct_out_file)
+
+  if not json_version:
+    Logger.info("There is no advertised version for this component stored in {0}".format(struct_out_file))
+    return
+
+  # On parallel command execution this should be executed by a single process at a time.
+  with FcntlBasedProcessLock(params.stack_select_lock_file, enabled = params.is_parallel_execution_enabled, skip_fcntl_failures = True):
+    for package in stack_packages:
+      stack_select.select(package, json_version)
+
 
 
 def setup_config():

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/hbase_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/hbase_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/hbase_client.py
index 1c3f113..27cfe92 100644
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/hbase_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/hbase_client.py
@@ -20,7 +20,6 @@ limitations under the License.
 
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions import StackFeature
 from resource_management.libraries.functions.stack_features import check_stack_feature
@@ -56,9 +55,7 @@ class HbaseClientDefault(HbaseClient):
     import params
     env.set_params(params)
 
-    if params.version and check_stack_feature(StackFeature.ROLLING_UPGRADE, params.version): 
-      conf_select.select(params.stack_name, "hbase", params.version)
-
+    if params.version and check_stack_feature(StackFeature.ROLLING_UPGRADE, params.version):
       # phoenix may not always be deployed
       try:
         stack_select.select_packages(params.version)
@@ -66,13 +63,5 @@ class HbaseClientDefault(HbaseClient):
         print "Ignoring error due to missing phoenix-client"
         print str(e)
 
-
-      # set all of the hadoop clients since hbase client is upgraded as part
-      # of the final "CLIENTS" group and we need to ensure that hadoop-client
-      # is also set
-      conf_select.select(params.stack_name, "hadoop", params.version)
-      stack_select.select_packages(params.version)
-
-
 if __name__ == "__main__":
   HbaseClient().execute()

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/phoenix_queryserver.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/phoenix_queryserver.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/phoenix_queryserver.py
index 1621916..f16bb15 100644
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/phoenix_queryserver.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/phoenix_queryserver.py
@@ -17,7 +17,6 @@ limitations under the License.
 
 """
 
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions import StackFeature
 from resource_management.libraries.functions.stack_features import check_stack_feature
@@ -59,7 +58,6 @@ class PhoenixQueryServer(Script):
 
     if params.stack_version_formatted and check_stack_feature(StackFeature.PHOENIX, params.stack_version_formatted):     
       # phoenix uses hbase configs
-      conf_select.select(params.stack_name, "hbase", params.version)
       stack_select.select_packages(params.version)
 
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/upgrade.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/upgrade.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/upgrade.py
index dbeb55d..4d7a571 100644
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/upgrade.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/HBASE/package/scripts/upgrade.py
@@ -20,7 +20,6 @@ limitations under the License.
 """
 from resource_management import *
 from resource_management.core import shell
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions import StackFeature
 from resource_management.libraries.functions.stack_features import check_stack_feature
@@ -31,7 +30,6 @@ def prestart(env):
   import params
 
   if params.version and check_stack_feature(StackFeature.ROLLING_UPGRADE, params.version):
-    conf_select.select(params.stack_name, "hbase", params.version)
     stack_select.select_packages(params.version)
 
 def post_regionserver(env):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/FLUME/package/scripts/flume_handler.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/FLUME/package/scripts/flume_handler.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/FLUME/package/scripts/flume_handler.py
index d70d06a..dafd9ec 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/FLUME/package/scripts/flume_handler.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/FLUME/package/scripts/flume_handler.py
@@ -23,7 +23,6 @@ from flume import flume
 from flume import get_desired_state
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.flume_agent_helper import find_expected_agent_names
 from resource_management.libraries.functions.flume_agent_helper import get_flume_status
@@ -133,7 +132,6 @@ class FlumeHandler(Script):
       return
 
     Logger.info("Executing Flume Stack Upgrade pre-restart")
-    conf_select.select(params.stack_name, "flume", params.version)
     stack_select.select_packages(params.version)
     if params.upgrade_direction == Direction.UPGRADE:
       flume_upgrade.pre_start_restore()

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/hbase_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/hbase_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/hbase_client.py
index 2b83664..f82986e 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/hbase_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/hbase_client.py
@@ -20,7 +20,6 @@ limitations under the License.
 
 import sys
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 
 from hbase import hbase
@@ -33,7 +32,6 @@ class HbaseClient(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hbase", params.version)
       #Execute(format("iop-select set hbase-client {version}"))
       
       # phoenix may not always be deployed
@@ -43,10 +41,6 @@ class HbaseClient(Script):
         print "Ignoring error due to missing phoenix-client"
         print str(e)
 
-      # set all of the hadoop clients since hbase client is upgraded as part
-      # of the final "CLIENTS" group and we need to ensure that hadoop-client
-      # is also set
-      conf_select.select(params.stack_name, "hadoop", params.version)
       #Execute(format("iop-select set hadoop-client {version}"))
 
   def install(self, env):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/phoenix_queryserver.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/phoenix_queryserver.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/phoenix_queryserver.py
index 51b8c65..520bb44 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/phoenix_queryserver.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/phoenix_queryserver.py
@@ -17,7 +17,6 @@ limitations under the License.
 
 """
 
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions
 from resource_management.libraries.script import Script
@@ -55,7 +54,6 @@ class PhoenixQueryServer(Script):
 
     if Script.is_stack_greater_or_equal("4.2"):
       # phoenix uses hbase configs
-      conf_select.select(params.stack_name, "hbase", params.version)
       stack_select.select_packages(params.version)
 
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/upgrade.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/upgrade.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/upgrade.py
index f1024c5..c812a54 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/upgrade.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/upgrade.py
@@ -21,7 +21,6 @@ limitations under the License.
 from resource_management import *
 from resource_management.core.resources.system import Execute
 from resource_management.core import shell
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
 from resource_management.libraries.functions.decorator import retry
@@ -30,7 +29,6 @@ def prestart(env):
   import params
 
   if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-    conf_select.select(params.stack_name, "hbase", params.version)
     stack_select.select_packages(params.version)
 
 def post_regionserver(env):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/datanode.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/datanode.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/datanode.py
index 7f38a78..a34a9d9 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/datanode.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/datanode.py
@@ -18,7 +18,6 @@ limitations under the License.
 """
 import datanode_upgrade
 from hdfs_datanode import datanode
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management import *
 from resource_management.libraries.functions.version import compare_versions, format_stack_version
@@ -34,7 +33,7 @@ class DataNode(Script):
     Get the name or path to the hdfs binary depending on the stack and version.
     """
     import params
-    stack_to_comp = stack_select.get_package_name()
+    stack_to_comp = "hadoop-hdfs-datanode"
     if params.stack_name in stack_to_comp:
       return get_hdfs_binary(stack_to_comp[params.stack_name])
     return "hdfs"
@@ -79,7 +78,6 @@ class DataNode(Script):
     import params
     env.set_params(params)
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("iop-select set hadoop-hdfs-datanode {version}"))
 

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/hdfs_client.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/hdfs_client.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/hdfs_client.py
index 62c6dd0..752905e 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/hdfs_client.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/hdfs_client.py
@@ -18,7 +18,6 @@ limitations under the License.
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.security_commons import build_expectations, \
   cached_kinit_executor, get_params_from_filesystem, validate_security_config_properties, \
@@ -40,7 +39,6 @@ class HdfsClient(Script):
     import params
     env.set_params(params)
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
 
   def start(self, env, upgrade_type=None):

http://git-wip-us.apache.org/repos/asf/ambari/blob/0535ca64/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/journalnode.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/journalnode.py b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/journalnode.py
index 3f44de0..b0351c5 100755
--- a/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/journalnode.py
+++ b/ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HDFS/package/scripts/journalnode.py
@@ -18,7 +18,6 @@ limitations under the License.
 """
 
 from resource_management import *
-from resource_management.libraries.functions import conf_select
 from resource_management.libraries.functions import stack_select
 from resource_management.libraries.functions.version import compare_versions, \
   format_stack_version
@@ -46,7 +45,6 @@ class JournalNode(Script):
     env.set_params(params)
 
     if params.version and compare_versions(format_stack_version(params.version), '4.0.0.0') >= 0:
-      conf_select.select(params.stack_name, "hadoop", params.version)
       stack_select.select_packages(params.version)
       #Execute(format("iop-select set hadoop-hdfs-journalnode {version}"))
 


Mime
View raw message