ambari-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rle...@apache.org
Subject [01/11] ambari git commit: AMBARI-21135: Kafka service fails to start during EU from HDF 202 to 30 while resolving /etc/kafka/conf (jluniya)
Date Thu, 22 Jun 2017 14:38:06 GMT
Repository: ambari
Updated Branches:
  refs/heads/branch-feature-AMBARI-20859 8f03fd044 -> b5333870a


AMBARI-21135: Kafka service fails to start during EU from HDF 202 to 30 while resolving /etc/kafka/conf
(jluniya)


Project: http://git-wip-us.apache.org/repos/asf/ambari/repo
Commit: http://git-wip-us.apache.org/repos/asf/ambari/commit/23760e71
Tree: http://git-wip-us.apache.org/repos/asf/ambari/tree/23760e71
Diff: http://git-wip-us.apache.org/repos/asf/ambari/diff/23760e71

Branch: refs/heads/branch-feature-AMBARI-20859
Commit: 23760e71a573da20d83e026d4a2e46177cada15b
Parents: e7fc3a6
Author: Jayush Luniya <jluniya@hortonworks.com>
Authored: Wed Jun 21 12:17:13 2017 -0700
Committer: Jayush Luniya <jluniya@hortonworks.com>
Committed: Wed Jun 21 12:17:13 2017 -0700

----------------------------------------------------------------------
 .../main/resources/custom_actions/scripts/install_packages.py  | 6 ++++++
 1 file changed, 6 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/ambari/blob/23760e71/ambari-server/src/main/resources/custom_actions/scripts/install_packages.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/custom_actions/scripts/install_packages.py b/ambari-server/src/main/resources/custom_actions/scripts/install_packages.py
index a4a7a8c..eb3fb5d 100644
--- a/ambari-server/src/main/resources/custom_actions/scripts/install_packages.py
+++ b/ambari-server/src/main/resources/custom_actions/scripts/install_packages.py
@@ -36,6 +36,7 @@ from resource_management.libraries.functions.stack_select import get_stack_versi
 from resource_management.libraries.functions.version import format_stack_version
 from resource_management.libraries.functions.repo_version_history \
     import read_actual_version_from_history_file, write_actual_version_to_history_file, REPO_VERSION_HISTORY_FILE
+from resource_management.core.resources.system import Link
 from resource_management.libraries.functions import StackFeature
 from resource_management.libraries.functions import packages_analyzer
 from resource_management.libraries.functions.repository_util import create_repo_files, CommandRepository
@@ -198,6 +199,11 @@ class InstallPackages(Script):
       Logger.info("Configuration symlinks are not needed for {0}".format(stack_version))
       return
 
+    # After upgrading hdf-select package from HDF-2.X to HDF-3.Y, we need to create this
symlink
+    if self.stack_name.upper() == "HDF" \
+            and not os.path.exists("/usr/bin/conf-select") and os.path.exists("/usr/bin/hdfconf-select"):
+      Link("/usr/bin/conf-select", to = "/usr/bin/hdfconf-select")
+
     for package_name, directories in conf_select.get_package_dirs().iteritems():
       conf_selector_name = stack_tools.get_stack_tool_name(stack_tools.CONF_SELECTOR_NAME)
       Logger.info("The current cluster stack of {0} does not require backing up configurations;
"


Mime
View raw message