ambari-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vsai...@apache.org
Subject [09/13] ambari git commit: AMBARI-20885.Convert all Ambari Views to use yarn package manager(Venkata Sairam)
Date Sun, 30 Apr 2017 18:33:49 GMT
http://git-wip-us.apache.org/repos/asf/ambari/blob/d293ec1d/contrib/views/hive-next/pom.xml
----------------------------------------------------------------------
diff --git a/contrib/views/hive-next/pom.xml b/contrib/views/hive-next/pom.xml
index c0eb774..578a82c 100644
--- a/contrib/views/hive-next/pom.xml
+++ b/contrib/views/hive-next/pom.xml
@@ -242,29 +242,35 @@
       <plugin>
         <groupId>com.github.eirslett</groupId>
         <artifactId>frontend-maven-plugin</artifactId>
-        <version>1.3</version>
+        <version>1.4</version>
         <configuration>
           <nodeVersion>v4.5.0</nodeVersion>
-          <npmVersion>2.15.0</npmVersion>
+          <yarnVersion>v0.23.2</yarnVersion>
           <workingDirectory>src/main/resources/ui/hive-web/</workingDirectory>
           <npmInheritsProxyConfigFromMaven>false</npmInheritsProxyConfigFromMaven>
+          <!-- setting npm_config_tmp environment variable is a workaround for
+               https://github.com/Medium/phantomjs/issues/673 -->
+          <environmentVariables>
+            <npm_config_tmp>/tmp/npm_config_tmp</npm_config_tmp>
+          </environmentVariables>
         </configuration>
         <executions>
           <execution>
-            <id>install node and npm</id>
+            <id>install node and yarn</id>
             <phase>generate-sources</phase>
             <goals>
-              <goal>install-node-and-npm</goal>
+              <goal>install-node-and-yarn</goal>
             </goals>
           </execution>
           <execution>
-            <id>npm install</id>
+            <id>yarn install --pure-lockfile</id>
             <phase>generate-sources</phase>
             <goals>
-              <goal>npm</goal>
+              <goal>yarn</goal>
             </goals>
             <configuration>
               <arguments>install --python="${project.basedir}/../src/main/unix/ambari-python-wrap"
--unsafe-perm</arguments>
+              <arguments>--ignore-engines</arguments>
             </configuration>
           </execution>
         </executions>

http://git-wip-us.apache.org/repos/asf/ambari/blob/d293ec1d/contrib/views/hive-next/src/main/resources/ui/hive-web/bower.json
----------------------------------------------------------------------
diff --git a/contrib/views/hive-next/src/main/resources/ui/hive-web/bower.json b/contrib/views/hive-next/src/main/resources/ui/hive-web/bower.json
index d029eff..62861b2 100644
--- a/contrib/views/hive-next/src/main/resources/ui/hive-web/bower.json
+++ b/contrib/views/hive-next/src/main/resources/ui/hive-web/bower.json
@@ -20,7 +20,8 @@
     "pretender": "0.1.0",
     "ember-uploader": "0.3.9",
     "polestar": "https://github.com/hortonworks/polestar.git#0.7.2",
-    "voyager": "https://github.com/hortonworks/voyager.git#0.7.2"
+    "voyager": "https://github.com/hortonworks/voyager.git#0.7.2",
+    "font-awesome": "^4.7.0"
   },
   "resolutions": {
     "ember": "1.10.0"

http://git-wip-us.apache.org/repos/asf/ambari/blob/d293ec1d/contrib/views/hive-next/src/main/resources/ui/hive-web/package.json
----------------------------------------------------------------------
diff --git a/contrib/views/hive-next/src/main/resources/ui/hive-web/package.json b/contrib/views/hive-next/src/main/resources/ui/hive-web/package.json
index 623f14f..545cefd 100644
--- a/contrib/views/hive-next/src/main/resources/ui/hive-web/package.json
+++ b/contrib/views/hive-next/src/main/resources/ui/hive-web/package.json
@@ -10,7 +10,7 @@
     "start": "ember server",
     "build": "ember build",
     "test": "ember test",
-    "preinstall": "chmod +x node/node_modules/npm/bin/node-gyp-bin/node-gyp",
+    "preinstall": "",
     "postinstall": "node node_modules/.bin/bower --allow-root install"
   },
   "repository": "https://github.com/stefanpenner/ember-cli",
@@ -23,17 +23,18 @@
     "body-parser": "^1.2.0",
     "bower": ">= 1.3.12",
     "broccoli-asset-rev": "^2.0.0",
+    "ember-ajax": "^2.0.1",
     "broccoli-sass": "^0.6.3",
     "ember-cli": "0.2.2",
     "ember-cli-autoprefixer": "0.4.1",
     "ember-cli-blanket": "^0.5.0",
+    "ember-cli-moment-shim": "3.0.1",
     "ember-cli-content-security-policy": "0.3.0",
-    "ember-cli-font-awesome": "0.0.4",
+    "ember-font-awesome": "2.2.0",
     "ember-cli-htmlbars": "0.7.4",
-    "ember-cli-ic-ajax": "0.1.1",
     "ember-cli-inject-live-reload": "^1.3.0",
     "ember-cli-jquery-ui": "0.0.12",
-    "ember-cli-moment": "0.0.1",
+    "ember-moment": "7.2.0",
     "ember-cli-pretender": "^0.3.1",
     "ember-cli-qunit": "0.3.14",
     "ember-cli-selectize": "0.0.19",


Mime
View raw message