ambari-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nc...@apache.org
Subject [44/50] [abbrv] ambari git commit: AMBARI-19711 Unable to register HDP version 2.6.0.0 on cluster with HDP 2.5.3.0 (atkach)
Date Wed, 25 Jan 2017 18:57:33 GMT
AMBARI-19711 Unable to register HDP version 2.6.0.0 on cluster with HDP 2.5.3.0 (atkach)


Project: http://git-wip-us.apache.org/repos/asf/ambari/repo
Commit: http://git-wip-us.apache.org/repos/asf/ambari/commit/75bf160c
Tree: http://git-wip-us.apache.org/repos/asf/ambari/tree/75bf160c
Diff: http://git-wip-us.apache.org/repos/asf/ambari/diff/75bf160c

Branch: refs/heads/branch-dev-patch-upgrade
Commit: 75bf160ce8dfd2fdd148f0dc7f857336c57a8b81
Parents: 18e58ff
Author: Andrii Tkach <atkach@apache.org>
Authored: Wed Jan 25 14:31:16 2017 +0200
Committer: Andrii Tkach <atkach@apache.org>
Committed: Wed Jan 25 14:37:01 2017 +0200

----------------------------------------------------------------------
 .../controllers/stackVersions/StackVersionsCreateCtrl.js       | 6 ++++++
 1 file changed, 6 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/ambari/blob/75bf160c/ambari-admin/src/main/resources/ui/admin-web/app/scripts/controllers/stackVersions/StackVersionsCreateCtrl.js
----------------------------------------------------------------------
diff --git a/ambari-admin/src/main/resources/ui/admin-web/app/scripts/controllers/stackVersions/StackVersionsCreateCtrl.js
b/ambari-admin/src/main/resources/ui/admin-web/app/scripts/controllers/stackVersions/StackVersionsCreateCtrl.js
index 3c16963..b3c27dc 100644
--- a/ambari-admin/src/main/resources/ui/admin-web/app/scripts/controllers/stackVersions/StackVersionsCreateCtrl.js
+++ b/ambari-admin/src/main/resources/ui/admin-web/app/scripts/controllers/stackVersions/StackVersionsCreateCtrl.js
@@ -284,6 +284,12 @@ angular.module('ambariAdminConsole')
     $scope.editVersionDisabled = true;
     delete $scope.updateObj.href;
     $scope.updateObj.operating_systems = [];
+    angular.forEach($scope.osList, function (os) {
+      os.OperatingSystems.ambari_managed_repositories = !$scope.useRedhatSatellite;
+      if (os.selected) {
+        $scope.updateObj.operating_systems.push(os);
+      }
+    });
 
     var skip = $scope.skipValidation || $scope.useRedhatSatellite;
     return Stack.validateBaseUrls(skip, $scope.osList, $scope.upgradeStack).then(function
(invalidUrls) {


Mime
View raw message