ambari-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nc...@apache.org
Subject [49/50] [abbrv] ambari git commit: AMBARI-18630. For rolling upgrade of Kafka 0.10.0.1, set configs for backward compatibility (ncole)
Date Wed, 19 Oct 2016 16:48:00 GMT
AMBARI-18630.  For rolling upgrade of Kafka 0.10.0.1, set configs for backward compatibility
(ncole)


Project: http://git-wip-us.apache.org/repos/asf/ambari/repo
Commit: http://git-wip-us.apache.org/repos/asf/ambari/commit/3d6ddc2a
Tree: http://git-wip-us.apache.org/repos/asf/ambari/tree/3d6ddc2a
Diff: http://git-wip-us.apache.org/repos/asf/ambari/diff/3d6ddc2a

Branch: refs/heads/branch-dev-patch-upgrade
Commit: 3d6ddc2af5de4c489f651eb61984e44e0eb5d04d
Parents: 2a2c557
Author: Nate Cole <ncole@hortonworks.com>
Authored: Tue Oct 18 17:04:15 2016 -0400
Committer: Nate Cole <ncole@hortonworks.com>
Committed: Wed Oct 19 09:48:55 2016 -0400

----------------------------------------------------------------------
 .../resources/stacks/HDP/2.3/upgrades/config-upgrade.xml    | 5 +++++
 .../main/resources/stacks/HDP/2.3/upgrades/upgrade-2.5.xml  | 9 +++++++++
 .../resources/stacks/HDP/2.4/upgrades/config-upgrade.xml    | 5 +++++
 .../main/resources/stacks/HDP/2.4/upgrades/upgrade-2.5.xml  | 9 +++++++++
 4 files changed, 28 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/ambari/blob/3d6ddc2a/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/config-upgrade.xml
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/config-upgrade.xml b/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/config-upgrade.xml
index e8a2e2f..e0a95da 100644
--- a/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/config-upgrade.xml
+++ b/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/config-upgrade.xml
@@ -356,6 +356,11 @@
             <transfer operation="delete" delete-key="xasecure.audit.credential.provider.file"
/>
             <transfer operation="delete" delete-key="xasecure.audit.destination.db.batch.filespool.dir"
/>
           </definition>
+          <definition xsi:type="configure" id="hdp_2_5_0_0_add_protocol_compatibility">
+            <type>kafka-broker</type>
+            <set key="inter.broker.protocol.version" value="0.9.0.0" />
+            <set key="log.message.format.version" value="0.9.0.0" />
+          </definition>
         </changes>
       </component>
     </service>

http://git-wip-us.apache.org/repos/asf/ambari/blob/3d6ddc2a/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/upgrade-2.5.xml
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/upgrade-2.5.xml b/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/upgrade-2.5.xml
index e89d62b..f9012e7 100644
--- a/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/upgrade-2.5.xml
+++ b/ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/upgrade-2.5.xml
@@ -516,6 +516,14 @@
           <message>-- If keytabs are managed manually, create the required ranger keytabs
in the locations specified in ranger config and restart Ranger components.</message>
         </task>
       </execute-stage>
+      
+      <execute-stage service="KAFKA" component="KAFKA_BROKER" title="Kafka Property Removal">
+        <task xsi:type="manual">
+          <message>Kafka Brokers have been upgraded with version compatability.</message>
+          <message>Config property "inter.broker.protocol.version" should be removed
at your convenience.</message>
+          <message>Config property "log.message.format.version" should be removed when
all clients have been upgraded.</message>
+        </task>
+      </execute-stage>
 
       <execute-stage service="HDFS" component="NAMENODE" title="Execute HDFS Finalize">
         <task xsi:type="execute" hosts="master">
@@ -986,6 +994,7 @@
       <component name="KAFKA_BROKER">
         <pre-upgrade>
           <task xsi:type="configure" id="hdp_2_5_0_0_remove_ranger_kafka_audit_db" />
+          <task xsi:type="configure" id="hdp_2_5_0_0_add_protocol_compatibility" />
         </pre-upgrade>
         
         <pre-downgrade/>

http://git-wip-us.apache.org/repos/asf/ambari/blob/3d6ddc2a/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/config-upgrade.xml
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/config-upgrade.xml b/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/config-upgrade.xml
index e127dff..898150d 100644
--- a/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/config-upgrade.xml
+++ b/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/config-upgrade.xml
@@ -226,6 +226,11 @@
             <transfer operation="delete" delete-key="xasecure.audit.credential.provider.file"
/>
             <transfer operation="delete" delete-key="xasecure.audit.destination.db.batch.filespool.dir"
/>
           </definition>
+          <definition xsi:type="configure" id="hdp_2_5_0_0_add_protocol_compatibility">
+            <type>kafka-broker</type>
+            <set key="inter.broker.protocol.version" value="0.9.0.0" />
+            <set key="log.message.format.version" value="0.9.0.0" />
+          </definition>
         </changes>
       </component>
     </service>

http://git-wip-us.apache.org/repos/asf/ambari/blob/3d6ddc2a/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/upgrade-2.5.xml
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/upgrade-2.5.xml b/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/upgrade-2.5.xml
index fa1a555..f6a17eb 100644
--- a/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/upgrade-2.5.xml
+++ b/ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/upgrade-2.5.xml
@@ -501,6 +501,14 @@
           <message>-- If keytabs are managed manually, create the required ranger keytabs
in the locations specified in ranger config and restart Ranger components.</message>
         </task>
       </execute-stage>
+      
+      <execute-stage service="KAFKA" component="KAFKA_BROKER" title="Kafka Property Removal">
+        <task xsi:type="manual">
+          <message>Kafka Brokers have been upgraded with version compatability.</message>
+          <message>Config property "inter.broker.protocol.version" should be removed
at your convenience.</message>
+          <message>Config property "log.message.format.version" should be removed when
all clients have been upgraded.</message>
+        </task>
+      </execute-stage>
 
       <execute-stage service="HDFS" component="NAMENODE" title="Execute HDFS Finalize">
         <task xsi:type="execute" hosts="master">
@@ -618,6 +626,7 @@
       <component name="KAFKA_BROKER">
         <pre-upgrade>
           <task xsi:type="configure" id="hdp_2_5_0_0_remove_ranger_kafka_audit_db" />
+          <task xsi:type="configure" id="hdp_2_5_0_0_add_protocol_compatibility" />
         </pre-upgrade>
 
         <pre-downgrade /> <!--  no-op to prevent config changes on downgrade -->


Mime
View raw message