ambari-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aonis...@apache.org
Subject ambari git commit: AMBARI-18043. Not able to proceed with RU downgrade due to spark clients failing to install (aonishuk)
Date Fri, 05 Aug 2016 13:55:22 GMT
Repository: ambari
Updated Branches:
  refs/heads/branch-2.4 37f714368 -> 80371f6ec


AMBARI-18043. Not able to proceed with RU downgrade due to spark clients failing to install
(aonishuk)


Project: http://git-wip-us.apache.org/repos/asf/ambari/repo
Commit: http://git-wip-us.apache.org/repos/asf/ambari/commit/80371f6e
Tree: http://git-wip-us.apache.org/repos/asf/ambari/tree/80371f6e
Diff: http://git-wip-us.apache.org/repos/asf/ambari/diff/80371f6e

Branch: refs/heads/branch-2.4
Commit: 80371f6ec557de127ba0935fbdb9aaff13d3fa5e
Parents: 37f7143
Author: Andrew Onishuk <aonishuk@hortonworks.com>
Authored: Fri Aug 5 16:55:02 2016 +0300
Committer: Andrew Onishuk <aonishuk@hortonworks.com>
Committed: Fri Aug 5 16:55:17 2016 +0300

----------------------------------------------------------------------
 .../main/python/resource_management/libraries/functions/version.py | 2 +-
 .../common-services/SPARK/1.2.1/package/scripts/params.py          | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/ambari/blob/80371f6e/ambari-common/src/main/python/resource_management/libraries/functions/version.py
----------------------------------------------------------------------
diff --git a/ambari-common/src/main/python/resource_management/libraries/functions/version.py
b/ambari-common/src/main/python/resource_management/libraries/functions/version.py
index 01daf08..2500430 100644
--- a/ambari-common/src/main/python/resource_management/libraries/functions/version.py
+++ b/ambari-common/src/main/python/resource_management/libraries/functions/version.py
@@ -42,7 +42,7 @@ def format_stack_version(input):
   if input:
     if "-" in input:
       input_array = input.split("-")
-      input = input_array[1]
+      input = input_array[0]
 
     input = re.sub(r'^\D+', '', input)
     input = re.sub(r'\D+$', '', input)

http://git-wip-us.apache.org/repos/asf/ambari/blob/80371f6e/ambari-server/src/main/resources/common-services/SPARK/1.2.1/package/scripts/params.py
----------------------------------------------------------------------
diff --git a/ambari-server/src/main/resources/common-services/SPARK/1.2.1/package/scripts/params.py
b/ambari-server/src/main/resources/common-services/SPARK/1.2.1/package/scripts/params.py
index 6636643..5a14ad1 100644
--- a/ambari-server/src/main/resources/common-services/SPARK/1.2.1/package/scripts/params.py
+++ b/ambari-server/src/main/resources/common-services/SPARK/1.2.1/package/scripts/params.py
@@ -58,7 +58,7 @@ stack_name = status_params.stack_name
 stack_root = Script.get_stack_root()
 stack_version_unformatted = config['hostLevelParams']['stack_version']
 if upgrade_direction == Direction.DOWNGRADE:
-  stack_version_unformatted = config['commandParams']['original_stack']
+  stack_version_unformatted = config['commandParams']['original_stack'].split("-")[1]
 stack_version_formatted = format_stack_version(stack_version_unformatted)
 host_sys_prepped = default("/hostLevelParams/host_sys_prepped", False)
 


Mime
View raw message