ambari-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aonis...@apache.org
Subject [1/2] ambari git commit: AMBARI-17502. RU/EU Install packages fails on suse (aonishuk)
Date Wed, 06 Jul 2016 14:59:11 GMT
Repository: ambari
Updated Branches:
  refs/heads/branch-2.4 8005e77ce -> ed5bcbf9e
  refs/heads/trunk bba526e3d -> 6d00d3988


AMBARI-17502. RU/EU Install packages fails on suse (aonishuk)


Project: http://git-wip-us.apache.org/repos/asf/ambari/repo
Commit: http://git-wip-us.apache.org/repos/asf/ambari/commit/6d00d398
Tree: http://git-wip-us.apache.org/repos/asf/ambari/tree/6d00d398
Diff: http://git-wip-us.apache.org/repos/asf/ambari/diff/6d00d398

Branch: refs/heads/trunk
Commit: 6d00d3988d37353e009cade9458c534b5e3d83d9
Parents: bba526e
Author: Andrew Onishuk <aonishuk@hortonworks.com>
Authored: Wed Jul 6 17:58:17 2016 +0300
Committer: Andrew Onishuk <aonishuk@hortonworks.com>
Committed: Wed Jul 6 17:58:17 2016 +0300

----------------------------------------------------------------------
 .../resource_management/libraries/functions/packages_analyzer.py   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/ambari/blob/6d00d398/ambari-common/src/main/python/resource_management/libraries/functions/packages_analyzer.py
----------------------------------------------------------------------
diff --git a/ambari-common/src/main/python/resource_management/libraries/functions/packages_analyzer.py
b/ambari-common/src/main/python/resource_management/libraries/functions/packages_analyzer.py
index 7805907..7bbbd3d 100644
--- a/ambari-common/src/main/python/resource_management/libraries/functions/packages_analyzer.py
+++ b/ambari-common/src/main/python/resource_management/libraries/functions/packages_analyzer.py
@@ -297,7 +297,7 @@ def verifyDependencies():
     cmd = ['/usr/bin/yum', '-d', '0', '-e', '0', 'check', 'dependencies']
     check_str = "has missing requires|Error:"
   elif OSCheck.is_suse_family():
-    cmd = ['/usr/bin/zypper', '--quiet', '--non-interactive' 'verify', '--dry-run']
+    cmd = ['/usr/bin/zypper', '--quiet', '--non-interactive', 'verify', '--dry-run']
     check_str = "\d+ new package(s)? to install"
   elif OSCheck.is_ubuntu_family():
     cmd = ['/usr/bin/apt-get', '-qq', 'check']


Mime
View raw message