ambari-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From onechipore...@apache.org
Subject ambari git commit: AMBARI-13179. Cannot edit configs after making older config as current (onechiporenko)
Date Tue, 22 Sep 2015 10:08:49 GMT
Repository: ambari
Updated Branches:
  refs/heads/branch-2.1.2 87fd28f1a -> 266d0cf9f


AMBARI-13179. Cannot edit configs after making older config as current (onechiporenko)


Project: http://git-wip-us.apache.org/repos/asf/ambari/repo
Commit: http://git-wip-us.apache.org/repos/asf/ambari/commit/266d0cf9
Tree: http://git-wip-us.apache.org/repos/asf/ambari/tree/266d0cf9
Diff: http://git-wip-us.apache.org/repos/asf/ambari/diff/266d0cf9

Branch: refs/heads/branch-2.1.2
Commit: 266d0cf9f9fb455ad25895c6102442581ed29735
Parents: 87fd28f
Author: Oleg Nechiporenko <onechiporenko@apache.org>
Authored: Tue Sep 22 13:06:26 2015 +0300
Committer: Oleg Nechiporenko <onechiporenko@apache.org>
Committed: Tue Sep 22 13:06:26 2015 +0300

----------------------------------------------------------------------
 ambari-web/app/mixins/common/configs/configs_loader.js | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/ambari/blob/266d0cf9/ambari-web/app/mixins/common/configs/configs_loader.js
----------------------------------------------------------------------
diff --git a/ambari-web/app/mixins/common/configs/configs_loader.js b/ambari-web/app/mixins/common/configs/configs_loader.js
index 7e86921..4e64fb3 100644
--- a/ambari-web/app/mixins/common/configs/configs_loader.js
+++ b/ambari-web/app/mixins/common/configs/configs_loader.js
@@ -130,8 +130,8 @@ App.ConfigsLoader = Em.Mixin.create(App.GroupsMappingMixin, {
     this.set('versionLoaded', false);
     version = version || this.get('currentDefaultVersion');
     if (version === this.get('currentDefaultVersion') && (!switchToGroup || switchToGroup.get('isDefault')))
{
-      this.loadCurrentVersions();
       this.set('selectedVersion', this.get('currentDefaultVersion'));
+      this.loadCurrentVersions();
     } else {
       //version of non-default group require properties from current version of default group
to correctly display page
       var versions = (this.isVersionDefault(version)) ? [version] : [this.get('currentDefaultVersion'),
version];


Mime
View raw message