allura-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Igor Bondarenko" <jetmi...@gmail.com>
Subject [allura:tickets] #7948 Cursor position often wrong in new markdown editor
Date Tue, 11 Aug 2015 14:33:22 GMT
- **status**: open --> review
- **Comment**:

Closed #835. `ib/7948`

Updated SimpleMDE to 1.5.0 and it fixes the issue for me.

Full screen mode has been added in this version. I've changed some css for it to work and
it works fine on the ticket edit for example, but it it doesn't currently work for comments
due to [this bug](https://github.com/NextStepWebs/simplemde-markdown-editor/issues/43).

We can disable full screen until it fixed or just wait a bit, seems like SimpleMDE's maintainer
reacts pretty quickly :)



---

** [tickets:#7948] Cursor position often wrong in new markdown editor**

**Status:** review
**Milestone:** unreleased
**Labels:** ux sf-current sf-4 
**Created:** Mon Aug 03, 2015 07:27 PM UTC by Dave Brondsema
**Last Updated:** Mon Aug 10, 2015 03:47 PM UTC
**Owner:** Igor Bondarenko


When editing text in the new markdown editor, the cursor can be off by a line (or few?). 
This seems to happen  reliably, but exact cause is not narrowed down yet.  Seems to only be
when editing existing content, not when creating new content (even pasting the exact same
text).  I think it has to do with the initial height of the input area being tall.  Sometimes
I can get the cursor to work properly again if I add or delete enough rows to make the textarea
resize some amount.


---

Sent from forge-allura.apache.org because dev@allura.apache.org is subscribed to https://forge-allura.apache.org/p/allura/tickets/

To unsubscribe from further messages, a project admin can change settings at https://forge-allura.apache.org/p/allura/admin/tickets/options.
 Or, if this is a mailing list, you can unsubscribe from the mailing list.
Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message