allura-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Van Steenburgh" <>
Subject [allura:tickets] #6355 SCM Auth not working properly with some special chars in repo name [ss4315]
Date Tue, 02 Jul 2013 13:45:59 GMT
Blocked on 


** [tickets:#6355] SCM Auth not working properly with some special chars in repo name [ss4315]**

**Status:** blocked
**Labels:** support p2 
**Created:** Tue Jun 11, 2013 12:25 PM UTC by Chris Tsai
**Last Updated:** Mon Jul 01, 2013 02:43 PM UTC
**Owner:** Tim Van Steenburgh



>After the upgrade of our Hg projects in to Allura,
some projects (for instance and cannot be pushed to anymore.
The error message is:

>jal@orange:/opt/sdk/themes/nl.openu.stoer.course-theme$ hg push
pushing to ssh://
running ssh 'hg -R p/openu/nl.openu.stoer.course-theme serve --stdio'
searching for changes
2 changesets found
remote: abort: could not lock repository /hg/p/openu/nl.openu.stoer.course-theme: Permission
abort: unexpected response: empty string

>Other repositories on which we have identical rights do work. Permission setting on the
UI seem to be in order and we tried doing this a a developer and as an admin with the same
result. Has something gone wrong with the conversion, and can we fix this ourselves? I can't
find a way do do shell access to the new Allura repos to fix this.

>Thanks in advance,

>Jules Alberts (sf account joolza)

Permissions on the project settings seem fine, but <>
isn't returning the values as I would expect (they're all false instead of all true).

Also, I tried creating a few new repos on my test project that included punctuation, and they
don't seem to have the correct auth either:


On the other hand, this repo I created a while ago (to test when the repo name restrictions
were relaxed) seems to return auth properly: <>


Sent from because is subscribed to

To unsubscribe from further messages, a project admin can change settings at
 Or, if this is a mailing list, you can unsubscribe from the mailing list.
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message