airflow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bolke de Bruin <bdbr...@gmail.com>
Subject Apache Airflow 1.10.0b4
Date Sun, 01 Jul 2018 10:03:50 GMT
Hi All,

I have created a sdist package that is available at:

http://people.apache.org/~bolke/apache-airflow-1.10.0b4+incubating.tar.gz <http://people.apache.org/~bolke/apache-airflow-1.10.0b3+incubating.tar.gz>

In order to distinguish it from an actual (apache) release it is:

1. Marked as beta (python package managers do not install beta versions by default - PEP 440)
2. It is not signed
3. It is not at an official apache distribution location

You can also put something like this in a requirements.txt file:

git+
https://github.com/apache/incubator-airflow@v1-10-test#egg=apache-airflow[celery,crypto,emr,hive,hdfs,ldap,mysql,postgres,redis,slack,s3
<https://github.com/apache/incubator-airflow@v1-10-test#egg=apache-airflow[celery,crypto,emr,hive,hdfs,ldap,mysql,postgres,redis,slack,s3>]
<https://github.com/rodrigc/incubator-airflow@master#egg=apache-airflow[celery,crypto,emr,hive,hdfs,ldap,mysql,postgres,redis,slack,s3]
<https://github.com/rodrigc/incubator-airflow@master#egg=apache-airflow[celery,crypto,emr,hive,hdfs,ldap,mysql,postgres,redis,slack,s3]>>

and then "pip install -r requirements.txt”.

I hope that after this beta we can go to RC and start voting on 1.10 (really)

Cheers
Bolke
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message