airflow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maxime Beauchemin <maximebeauche...@gmail.com>
Subject Re: Proposal: Set Celery 4.0 as a minimum as Celery 4 is unsupported
Date Tue, 19 Sep 2017 17:26:41 GMT
Quick note that Celery 4 drops support for the SQLAlchemy broker which was
convenient for running unit tests. We'll have to move to using Redis for
tests which is trivial on Travis.

On Sat, Sep 16, 2017 at 8:45 AM, Ash Berlin-Taylor <
ash_airflowlist@firemirror.com> wrote:

> +1 from us, we're running on Celery 4.0.2 in production on Airflow 1.8.2
> (4.1 wasn't out when we started and haven't upgraded in prod yet)
>
>
> > On 16 Sep 2017, at 16:35, Bolke de Bruin <bdbruin@gmail.com> wrote:
> >
> > Hi,
> >
> > Some refactoring of the Celery config is underway and as some of the
> options have changed between Celery 3 and 4 I have asked the question
> whether Celery 3 is still supported. Apparently it is not (
> https://github.com/celery/celery/issues/4258 <https://github.com/celery/
> celery/issues/4258>).
> >
> > As Celery 3 is also 2 major releases behind I propose to set Celery 4.0
> as a minimum supported version with Celery 4.1 being the recommend version.
> I think this is also important as we do see some intermittent issues with
> Celery that are reported to us but are, most likely, issues in Celery. I
> don’t want to take care of those as they are difficult to debug.
> >
> > I would like to do this per 1.9.0. The 1.8.X branch can still support
> Celery 3.
> >
> > Cheers
> > Bolke
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message