airflow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rafael Barbosa <rrbarb...@gmail.com>
Subject alembic.util.exc.CommandError: Can't locate revision identified by '8504051e801b'
Date Wed, 17 May 2017 12:49:08 GMT
Hi,

I attempted to move our airflow installation from python2.7 to python3.6.
As far as I can tell, that is the only change in the airflow system. I am
running version 1.7.1.3. When starting the new system, I the following
error thrown a couple times:

`alembic.util.exc.CommandError: Can't locate revision identified by
'8504051e801b'`

I am still able to run and test tasks manually, but the scheduler does not
seem to work. When I start to the python2.7 installation, everything works
as expected.

I tried finding the source of the problem, but I am not familiar with
alembic. Running `airflow initdb` or `upgradedb` give me the same error.
This is what I get if I run `alembic history` from the airflow folder

```
$> alembic history
[2017-05-17 12:20:29,233] {__init__.py:36} INFO - Using executor
LocalExecutor
1968acfc09e3 -> 2e82aab8ef20 (head), rename user table
bba5a7cfc896 -> 1968acfc09e3, add is_encrypted column to variable table
bbc73705a13e -> bba5a7cfc896, Add a column to track the encryption state of
the 'Extra' field in connection
4446e08588 -> bbc73705a13e, Add notification_sent column to sla_miss
561833c1c74b -> 4446e08588, dagrun start end
40e67319e3a9 -> 561833c1c74b, add password column to user
2e541a1dcfed -> 40e67319e3a9, dagrun_config
1b38cef5b76e -> 2e541a1dcfed, task_duration
502898887f84 -> 1b38cef5b76e, add dagrun
52d714495f0 -> 502898887f84, Adding extra to Log
338e90f54d61 -> 52d714495f0, job_id indices
13eb55f81627 -> 338e90f54d61, More logging into task_isntance
1507a7289a2f -> 13eb55f81627, maintain history for compatibility with
earlier migrations
e3a246e0dc1 -> 1507a7289a2f, create is_encrypted
<base> -> e3a246e0dc1, current schema
```

What am I missing?

Thanks,
Rafael

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message