airflow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijay Bhat <vijaysb...@gmail.com>
Subject Re: Duration chart doesn't show Y axis label
Date Sat, 20 May 2017 14:10:18 GMT
Michael: Glad to take a look. Can you attach a 'before' screenshot for
AIRFLOW-1082 so we know how it used to behave?

-Vijay

On Sat, May 20, 2017 at 6:33 AM, Michael Erdely <mjerdely@gmail.com> wrote:

> Vijay,
>
> If you take this on, can you please keep these couple bugs in mind:
>
> AIRFLOW-1205 <https://issues.apache.org/jira/browse/AIRFLOW-1205> Graphs -
> "Cumulative Duration" checkbox on "Task Duration" graph doesn't work
> AIRFLOW-1082 <https://issues.apache.org/jira/browse/AIRFLOW-1082> Graph
> legend pushes/compresses graph to flat lines if many operators are present
>
> Thanks,
> Michael
>
>
> On Fri, May 19, 2017 at 1:06 PM Vijay Bhat <vijaysbhat@gmail.com> wrote:
>
> > Hi all,
> >
> > I noticed that the duration chart isn't showing the Y axis label anymore.
> > After digging into the commit history, I found the bug was introduced in
> > this PR for using static nvd3 resources (reverting the change makes the
> > label show up again):
> >
> > https://github.com/apache/incubator-airflow/pull/2035
> >
> > Bolke, what's the right way to fix this? The label isn't showing because
> it
> > is getting rendered outside the chart container, but all the offsets are
> > being calculated / hardcoded in nvd3.js and not in any airflow code.
> >
> > I'd like to fix this because the Y axis label also has the units of time
> > used in the chart.
> >
> > Thanks,
> > Vijay
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message