airflow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Erdely <mjerd...@gmail.com>
Subject Re: Duration chart doesn't show Y axis label
Date Mon, 22 May 2017 18:30:27 GMT
Hi Vijay,

I have attached a before screenshot (below 1.8) for a generic dag to
AIRFLOW-1082 <https://issues.apache.org/jira/browse/AIRFLOW-1082>.

Basically, the key (ie list the operators) use to be below the graph.
With 1.8, the operators are listed above the graph but occupying the same
space so the graph gets compressed. If enough operators are present, the
graph gets flattened.

-Michael




On Sat, May 20, 2017 at 4:22 PM Michael Erdely <mjerdely@gmail.com> wrote:

> Will do first thing Monday morning unless you need it sooner.
>
> -Michael
>
>
>
> On Sat, May 20, 2017 at 7:10 AM Vijay Bhat <vijaysbhat@gmail.com> wrote:
>
>> Michael: Glad to take a look. Can you attach a 'before' screenshot for
>> AIRFLOW-1082 so we know how it used to behave?
>>
>> -Vijay
>>
>> On Sat, May 20, 2017 at 6:33 AM, Michael Erdely <mjerdely@gmail.com>
>> wrote:
>>
>> > Vijay,
>> >
>> > If you take this on, can you please keep these couple bugs in mind:
>> >
>> > AIRFLOW-1205 <https://issues.apache.org/jira/browse/AIRFLOW-1205>
>> Graphs -
>> > "Cumulative Duration" checkbox on "Task Duration" graph doesn't work
>> > AIRFLOW-1082 <https://issues.apache.org/jira/browse/AIRFLOW-1082> Graph
>> > legend pushes/compresses graph to flat lines if many operators are
>> present
>> >
>> > Thanks,
>> > Michael
>> >
>> >
>> > On Fri, May 19, 2017 at 1:06 PM Vijay Bhat <vijaysbhat@gmail.com>
>> wrote:
>> >
>> > > Hi all,
>> > >
>> > > I noticed that the duration chart isn't showing the Y axis label
>> anymore.
>> > > After digging into the commit history, I found the bug was introduced
>> in
>> > > this PR for using static nvd3 resources (reverting the change makes
>> the
>> > > label show up again):
>> > >
>> > > https://github.com/apache/incubator-airflow/pull/2035
>> > >
>> > > Bolke, what's the right way to fix this? The label isn't showing
>> because
>> > it
>> > > is getting rendered outside the chart container, but all the offsets
>> are
>> > > being calculated / hardcoded in nvd3.js and not in any airflow code.
>> > >
>> > > I'd like to fix this because the Y axis label also has the units of
>> time
>> > > used in the chart.
>> > >
>> > > Thanks,
>> > > Vijay
>> > >
>> >
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message