airflow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russell Jurney <russell.jur...@gmail.com>
Subject DockerOperator - old API? What version/package API does this use?
Date Fri, 28 Apr 2017 03:51:47 GMT
I am trying to use DockerOperator and I get this error:

    from docker import Client, tls
ImportError: cannot import name 'Client'


There is no requirements.txt, so I can't figure out what docker API this
is, but it hasn't existed in the official docker Python module for ...
ever? I can't figure out how this is supposed to work.

I'm happy to fix it because... I have to, but can anyone comment on what is
going on here? What module and what version is this referring to? It does
not seem to be https://github.com/docker/docker-py, I even checked the 1.x
line and that doesn't match either.

Russell Jurney @rjurney <http://twitter.com/rjurney>
russell.jurney@gmail.com LI <http://linkedin.com/in/russelljurney> FB
<http://facebook.com/jurney> datasyndrome.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message