airflow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From twinkle sachdeva <twinkle.sachd...@gmail.com>
Subject Re: Regarding installation issue
Date Mon, 03 Oct 2016 15:00:38 GMT
Thanks Bolke. I will upgrade to python 2.7 and try.

Regards,
Twinkle

On Oct 3, 2016 6:28 PM, "Bolke de Bruin" <bdbruin@gmail.com> wrote:

> We don’t support python 2.6 .
>
> Please upgrade to at least 2.7.
>
> Bolke
>
> > Op 3 okt. 2016, om 08:23 heeft twinkle sachdeva <
> twinkle.sachdeva@gmail.com> het volgende geschreven:
> >
> > Hi,
> >
> > I have been trying to install Airflow on one of the VMs ( Python version
> :
> > 2.6.6 and Pip Version : 7.1.0 ).
> >
> > I am getting the following stack trace  ->
> >
> > creating build/docs
> >
> >    copying docs/index.txt -> build/docs
> >
> >    Converting docs/index.txt -> build/docs/index.html
> >
> >    Traceback (most recent call last):
> >
> >      File "<string>", line 1, in <module>
> >
> >      File "/tmp/pip-build-pCrt4S/markdown/setup.py", line 270, in
> <module>
> >
> >        'Topic :: Text Processing :: Markup :: HTML'
> >
> >      File "/usr/lib64/python2.6/distutils/core.py", line 152, in setup
> >
> >        dist.run_commands()
> >
> >      File "/usr/lib64/python2.6/distutils/dist.py", line 975, in
> > run_commands
> >
> >        self.run_command(cmd)
> >
> >      File "/usr/lib64/python2.6/distutils/dist.py", line 995, in
> > run_command
> >
> >        cmd_obj.run()
> >
> >      File
> > "/usr/lib/python2.6/site-packages/setuptools/command/install.py", line
> 53,
> > in run
> >
> >        return _install.run(self)
> >
> >      File "/usr/lib64/python2.6/distutils/command/install.py", line 577,
> > in run
> >
> >        self.run_command('build')
> >
> >      File "/usr/lib64/python2.6/distutils/cmd.py", line 333, in
> run_command
> >
> >        self.distribution.run_command(command)
> >
> >      File "/usr/lib64/python2.6/distutils/dist.py", line 995, in
> > run_command
> >
> >        cmd_obj.run()
> >
> >      File "/usr/lib64/python2.6/distutils/command/build.py", line 134,
> in
> > run
> >
> >        self.run_command(cmd_name)
> >
> >      File "/usr/lib64/python2.6/distutils/cmd.py", line 333, in
> run_command
> >
> >        self.distribution.run_command(command)
> >
> >      File "/usr/lib64/python2.6/distutils/dist.py", line 995, in
> > run_command
> >
> >        cmd_obj.run()
> >
> >      File "/tmp/pip-build-pCrt4S/markdown/setup.py", line 184, in run
> >
> >        out = template % self._get_context(src, outfile)
> >
> >      File "/tmp/pip-build-pCrt4S/markdown/setup.py", line 116, in
> > _get_context
> >
> >        c['body'] = self.md.convert(src)
> >
> >      File "build/lib/markdown/__init__.py", line 375, in convert
> >
> >        newRoot = treeprocessor.run(root)
> >
> >      File "build/lib/markdown/extensions/toc.py", line 229, in run
> >
> >        for el in doc.iter():
> >
> >    AttributeError: iter
> >
> >
> >
> >    ----------------------------------------
> >
> > Command "/usr/bin/python -c "import setuptools,
> > tokenize;__file__='/tmp/pip-build-pCrt4S/markdown/setup.
> py';exec(compile(getattr(tokenize,
> > 'open', open)(__file__).read().replace('\r\n', '\n'), __file__,
> 'exec'))"
> > install --record /tmp/pip-RYL54E-record/install-record.txt
> > --single-version-externally-managed --compile" failed with error code 1
> in
> > /tmp/pip-build-pCrt4S/markdown
> >
> >
> >
> > Please help.
> >
> >
> > Regards,
> >
> > Twinkle
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message