airflow-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Qian Yu <...@eharmony.com.INVALID>
Subject Airflow installation issue
Date Wed, 01 Jun 2016 20:51:25 GMT
Hi guys,
I am Qian, software engineer from eHarmony.
I am trying to install Airflow using pip, but I got some issue. It will be
very helpful if you can help me with that.
Thanks a lot.
Qian

DEPRECATION: Python 2.6 is no longer supported by the Python core team,
please upgrade your Python. A future version of pip will drop support for
Python 2.6

The directory '/home/qyu/.cache/pip/http' or its parent directory is not
owned by the current user and the cache has been disabled. Please check the
permissions and owner of that directory. If executing pip with sudo, you may
want sudo's -H flag.

The directory '/home/qyu/.cache/pip' or its parent directory is not owned by
the current user and caching wheels has been disabled. check the permissions
and owner of that directory. If executing pip with sudo, you may want sudo's
-H flag.

Collecting airflow[all]

/usr/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/
ssl_.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI
(Subject Name Indication) extension to TLS is not available on this
platform. This may cause the server to present an incorrect TLS certificate,
which can cause validation failures. You can upgrade to a newer version of
Python to solve this. For more information, see
https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.

  SNIMissingWarning

/usr/lib/python2.6/site-packages/pip/_vendor/requests/packages/urllib3/util/
ssl_.py:122: InsecurePlatformWarning: A true SSLContext object is not
available. This prevents urllib3 from configuring SSL appropriately and may
cause certain SSL connections to fail. You can upgrade to a newer version of
Python to solve this. For more information, see
https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarn
ing.

  InsecurePlatformWarning

  Downloading airflow-1.7.1.2.tar.gz (2.1MB)

    100% |████████████████████████████████|
2.1MB 506kB/s

Requirement already satisfied (use --upgrade to upgrade):
alembic<0.9,>=0.8.3 in /usr/lib/python2.6/site-packages (from airflow[all])

Requirement already satisfied (use --upgrade to upgrade): babel<2.0,>=1.3 in
/usr/lib/python2.6/site-packages (from airflow[all])

Requirement already satisfied (use --upgrade to upgrade):
chartkick<0.5,>=0.4.2 in /usr/lib/python2.6/site-packages (from
airflow[all])

Requirement already satisfied (use --upgrade to upgrade):
croniter<0.4,>=0.3.8 in /usr/lib/python2.6/site-packages (from airflow[all])

Requirement already satisfied (use --upgrade to upgrade): dill<0.3,>=0.2.2
in /usr/lib/python2.6/site-packages (from airflow[all])

Requirement already satisfied (use --upgrade to upgrade):
python-daemon<2.2,>=2.1.1 in /usr/lib/python2.6/site-packages (from
airflow[all])

Requirement already satisfied (use --upgrade to upgrade):
flask<0.11,>=0.10.1 in /usr/lib/python2.6/site-packages (from airflow[all])

Requirement already satisfied (use --upgrade to upgrade):
flask-admin<2.0.0,>=1.4.0 in /usr/lib/python2.6/site-packages (from
airflow[all])

Requirement already satisfied (use --upgrade to upgrade):
flask-cache<0.14,>=0.13.1 in /usr/lib/python2.6/site-packages (from
airflow[all])

Requirement already satisfied (use --upgrade to upgrade):
flask-login==0.2.11 in /usr/lib/python2.6/site-packages (from airflow[all])

Requirement already satisfied (use --upgrade to upgrade):
future<0.16,>=0.15.0 in /usr/lib/python2.6/site-packages (from airflow[all])

Requirement already satisfied (use --upgrade to upgrade): funcsigs<1,>=0.4
in /usr/lib/python2.6/site-packages (from airflow[all])

Requirement already satisfied (use --upgrade to upgrade):
gunicorn<19.4.0,>=19.3.0 in /usr/lib/python2.6/site-packages (from
airflow[all])

Requirement already satisfied (use --upgrade to upgrade): jinja2<3.0,>=2.7.3
in /usr/lib64/python2.6/site-packages (from airflow[all])

Collecting markdown<3.0,>=2.5.2 (from airflow[all])

  Downloading Markdown-2.6.6.zip (412kB)

    100% |████████████████████████████████|
419kB 2.7MB/s

Collecting pandas<1.0.0,>=0.15.2 (from airflow[all])

  Downloading pandas-0.18.1.tar.gz (7.3MB)

    100% |████████████████████████████████|
7.3MB 145kB/s

Collecting pygments<3.0,>=2.0.1 (from airflow[all])

  Downloading Pygments-2.1.3-py2.py3-none-any.whl (755kB)

    100% |████████████████████████████████|
757kB 1.4MB/s

Requirement already satisfied (use --upgrade to upgrade):
python-dateutil<3,>=2.3 in /usr/lib/python2.6/site-packages (from
airflow[all])

Collecting requests<3,>=2.5.1 (from airflow[all])

  Downloading requests-2.10.0-py2.py3-none-any.whl (506kB)

    100% |████████████████████████████████|
512kB 2.2MB/s

Collecting setproctitle<2,>=1.1.8 (from airflow[all])

  Downloading setproctitle-1.1.10.tar.gz

Requirement already satisfied (use --upgrade to upgrade): sqlalchemy>=0.9.8
in /usr/lib64/python2.6/site-packages (from airflow[all])

Collecting thrift<0.10,>=0.9.2 (from airflow[all])

  Downloading thrift-0.9.3.tar.gz

Collecting Flask-WTF==0.12 (from airflow[all])

  Downloading Flask_WTF-0.12-py2-none-any.whl

Collecting lxml>=3.3.4 (from airflow[all])

  Downloading lxml-3.6.0.tar.gz (3.7MB)

    100% |████████████████████████████████|
3.7MB 142kB/s

Requirement already satisfied (use --upgrade to upgrade): nose in
/usr/lib/python2.6/site-packages (from airflow[all])

Collecting nose-parameterized (from airflow[all])

  Downloading nose_parameterized-0.5.0-py2.py3-none-any.whl

Collecting mock (from airflow[all])

  Downloading mock-2.0.0-py2.py3-none-any.whl (56kB)

    100% |████████████████████████████████|
61kB 8.5MB/s

Collecting psycopg2>=2.6 (from airflow[all])

  Downloading psycopg2-2.6.1.tar.gz (371kB)

    100% |████████████████████████████████|
378kB 2.8MB/s

    Complete output from command python setup.py egg_info:

    running egg_info

    creating pip-egg-info/psycopg2.egg-info

    writing pip-egg-info/psycopg2.egg-info/PKG-INFO

    writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt

    writing dependency_links to
pip-egg-info/psycopg2.egg-info/dependency_links.txt

    writing pip-egg-info/psycopg2.egg-info/PKG-INFO

    writing top-level names to pip-egg-info/psycopg2.egg-info/top_level.txt

    writing dependency_links to
pip-egg-info/psycopg2.egg-info/dependency_links.txt

    writing manifest file 'pip-egg-info/psycopg2.egg-info/SOURCES.txt'

    warning: manifest_maker: standard file '-c' not found

    Error: pg_config executable not found.

    

    Please add the directory containing pg_config to the PATH

    or specify the full executable path with the option:

    

        python setup.py build_ext --pg-config /path/to/pg_config build ...

    

    or with the pg_config option in 'setup.cfg'.

    

    ----------------------------------------

Command "python setup.py egg_info" failed with error code 1 in
/tmp/pip-build-0VRxnG/psycopg2/





Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message