airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (Jira)" <>
Subject [jira] [Commented] (AIRFLOW-5561) Very old version of httplib2 installed when using gcp extra
Date Wed, 02 Oct 2019 11:09:00 GMT


ASF subversion and git services commented on AIRFLOW-5561:

Commit a206d7d846e9459d9f2611582191c6e5490e9f64 in airflow's branch refs/heads/v1-10-stable
from Camilo Martinez
[;h=a206d7d ]

[AIRFLOW-5561] Relax httplib2 version required for gcp extra (#6194)

As part of [AIRFLOW-3971] a minor version range dependency was
introduced that means that only older versions of httplib2 can
be used.

I'm relaxing this dependency as I tested with the latest 0.13.1
and it works correctly

(cherry picked from commit 4d4fda75333b1e6ae4e99b407ab2b1edc0d139d8)

> Very old version of httplib2 installed when using gcp extra
> -----------------------------------------------------------
>                 Key: AIRFLOW-5561
>                 URL:
>             Project: Apache Airflow
>          Issue Type: Bug
>          Components: gcp
>    Affects Versions: 1.10.3, 1.10.4, 1.10.5
>            Reporter: Camilo Martinez
>            Assignee: Kamil Bregula
>            Priority: Major
>             Fix For: 1.10.6
> After starting to use poetry to properly resolve airflow dependencies I faced network
issues that I pinpointed to httplib2 interactions with proxy in my corporate network.
> When making an http request I would get a "Network not reachable" exception
> I isolated the problem to happen when using a very old version of httplib2 while using
gcp extra which has a dependency range too strict (~=0.9.2)
> I noticed that this dependency used to be httplib2>=0.9.2 and it was changed as part
of AIRFLOW-3971  commit (91b856f) without a clear reason why a more strict dependency is

This message was sent by Atlassian Jira

View raw message