airflow-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AIRFLOW-3384) Allow higher versions of sqlalchemy and jinja
Date Sat, 24 Nov 2018 08:22:00 GMT

    [ https://issues.apache.org/jira/browse/AIRFLOW-3384?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16697694#comment-16697694
] 

ASF GitHub Bot commented on AIRFLOW-3384:
-----------------------------------------

jlricon closed pull request #4227: [AIRFLOW-3384] Allow higher versions of Sqlalchemy and
Jinja2
URL: https://github.com/apache/incubator-airflow/pull/4227
 
 
   

This is a PR merged from a forked repository.
As GitHub hides the original diff on merge, it is displayed below for
the sake of provenance:

As this is a foreign pull request (from a fork), the diff is supplied
below (as it won't show otherwise due to GitHub magic):

diff --git a/setup.py b/setup.py
index e651f5a66e..0c21f7d9ec 100644
--- a/setup.py
+++ b/setup.py
@@ -299,7 +299,7 @@ def do_setup():
             'dill>=0.2.2, <0.3',
             'flask>=0.12.4, <0.13',
             'flask-appbuilder==1.12.1',
-            'flask-admin==1.4.1',
+            'flask-admin==1.5.2',
             'flask-caching>=1.3.3, <1.4.0',
             'flask-login>=0.3, <0.5',
             'flask-swagger==0.2.13',
@@ -310,7 +310,7 @@ def do_setup():
             'gunicorn>=19.4.0, <20.0',
             'iso8601>=0.1.12',
             'json-merge-patch==0.2',
-            'jinja2>=2.7.3, <2.9.0',
+            'jinja2>=2.7.3, <=2.10.0',
             'lxml>=4.0.0',
             'markdown>=2.5.2, <3.0',
             'pandas>=0.17.1, <1.0.0',
@@ -322,7 +322,7 @@ def do_setup():
             'python-nvd3==0.15.0',
             'requests>=2.5.1, <3',
             'setproctitle>=1.1.8, <2',
-            'sqlalchemy>=1.1.15, <1.2.0',
+            'sqlalchemy>=1.1.15, <1.3.0',
             'tabulate>=0.7.5, <=0.8.2',
             'tenacity==4.8.0',
             'thrift>=0.9.2',


 

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> Allow higher versions of sqlalchemy and jinja
> ---------------------------------------------
>
>                 Key: AIRFLOW-3384
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-3384
>             Project: Apache Airflow
>          Issue Type: Improvement
>          Components: dependencies
>            Reporter: Jose Luis Ricon
>            Assignee: Jose Luis Ricon
>            Priority: Major
>
> At the moment airflow doesn't allow the installation of sqlalchemy version 1.2.11 and
jinja2==2.10 . Airflow works with both, and there is no reason to allow higher versions. Projects
downstream who are currently forcing the installation of said versions, overriding airflow's
dependencies, will benefit for this as it will allow for version-compatible installations
without loss in functionality.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message